summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-22 22:24:39 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-22 22:35:28 +0100
commit099f0d608f8432388d43aa898555a001ef5a4b75 (patch)
tree293e97ba580733843bd1501fec7f38821a3260bb
parentdev-util/android-tools: disable py3.9 (diff)
downloadgentoo-099f0d608f8432388d43aa898555a001ef5a4b75.tar.gz
gentoo-099f0d608f8432388d43aa898555a001ef5a4b75.tar.bz2
gentoo-099f0d608f8432388d43aa898555a001ef5a4b75.zip
dev-vcs/pre-commit: drop 3.0.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch44
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.0.4.ebuild56
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 41bca9891ba4..1ce7141a1a0d 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1 @@
-DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
diff --git a/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch b/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch
deleted file mode 100644
index 9845e1311da5..000000000000
--- a/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/tests/commands/install_uninstall_test.py
-+++ b/tests/commands/install_uninstall_test.py
-@@ -176,7 +176,7 @@
- def test_install_in_submodule_and_run(tempdir_factory, store):
- src_path = make_consuming_repo(tempdir_factory, 'script_hooks_repo')
- parent_path = git_dir(tempdir_factory)
-- cmd_output('git', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
-+ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
- git_commit(cwd=parent_path)
-
- sub_pth = os.path.join(parent_path, 'sub')
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -90,7 +90,7 @@
- git_dir_1 = git_dir(tempdir_factory)
- git_dir_2 = git_dir(tempdir_factory)
- git_commit(msg=in_conflicting_submodule.__name__, cwd=git_dir_2)
-- cmd_output('git', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
-+ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
- with cwd(os.path.join(git_dir_1, 'sub')):
- _make_conflict()
- yield
---- a/tests/repository_test.py
-+++ b/tests/repository_test.py
-@@ -443,7 +443,7 @@
- repo.join('main.go').write(main_go)
- cmd_output('git', '-C', str(repo), 'init', '.')
- cmd_output('git', '-C', str(repo), 'add', '.')
-- cmd_output('git', '-C', str(repo), 'submodule', 'add', str(sub), 'sub')
-+ cmd_output('git', '-C', str(repo), '-c', 'protocol.file.allow=always', 'submodule', 'add', str(sub), 'sub')
- git.commit(str(repo))
-
- config = make_config_from_repo(str(repo))
---- a/tests/staged_files_only_test.py
-+++ b/tests/staged_files_only_test.py
-@@ -207,7 +207,7 @@
- cmd_output('git', 'add', 'bar')
- git_commit()
- cmd_output(
-- 'git', 'submodule', 'add', repo_with_commits.path, 'sub',
-+ 'git', '-c', 'protocol.file.allow=always', 'submodule', 'add', repo_with_commits.path, 'sub',
- )
- checkout_submodule(repo_with_commits.rev1)
- cmd_output('git', 'add', 'sub')
diff --git a/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild b/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild
deleted file mode 100644
index 11b7b05c956f..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.20.0-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest