summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-12-20 12:12:54 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-12-20 12:13:35 -0800
commit0598f659734c3d29685112a64fcd4c07bd05dc78 (patch)
treec10469a21346618bfc164bc6c48b3aedef8fffda
parentllvm.org.eclass: fix manpage installation path (diff)
downloadgentoo-0598f659734c3d29685112a64fcd4c07bd05dc78.tar.gz
gentoo-0598f659734c3d29685112a64fcd4c07bd05dc78.tar.bz2
gentoo-0598f659734c3d29685112a64fcd4c07bd05dc78.zip
x11-themes/arc-theme: add 20221218
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20221218.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index ace0acc1d069..19487619d628 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -2,3 +2,4 @@ DIST arc-theme-20210412-pngs.tar.xz 159340 BLAKE2B 40027335b8b44ae38bfadfa52e088
DIST arc-theme-20210412.tar.xz 257248 BLAKE2B c525c3632670d8aa6b640baa8b3dddca6c5dd5f087734604c68d9140f810fc595f73db06f93b6193ba1c59a8cd85b87f5f6fda9777940adf36f3c436a8426810 SHA512 d3064546301e013a1e5a8db735346d74c73f37cbf808b7afeee6f88c820cea58ba6458fa63e1213377cdd33c8347167242e6f8f1eacf85ce212f3b2508c0bb80
DIST arc-theme-20220223.tar.xz 343044 BLAKE2B 7bdd3689eae270a97d5405c2eaf523b9d81284c1860d39de5f46a7c32d75dd24f745a5264d76625c08c2185ad87e65a99e93d39be753dc0304a86daa863df3cd SHA512 33a0e73e9951fcfe74f80af5e1449df23a5564d11a26b930cbc17b0f74887aedf2634579da1e0484e22465422f62559c801dbcd35221fbb7b7fc783671103aa4
DIST arc-theme-20220405.tar.xz 346512 BLAKE2B 49a25b302e6641b5234f0d3e4bddda84eb0136333b3c513dc9ca08be9b966c75c299289390cdd64c62bdeeed9f457ff01524b2da95029c78b32c3603aaff23c8 SHA512 16655b822548820945c5fd3c0bb809d1e55db887c3b5c5309f4acd82c4dd7dd8255d246d86025231c73a303e647bb61c7f9cdc63a04f813cfb79fadf27dec204
+DIST arc-theme-20221218.tar.xz 349456 BLAKE2B 26a8b6728c0c6d00568ea7804f6c73215f68baf756e20f71f093f3108a87a8d0a250b4fd8b8fb4d30feeb9ea8c936e00b4d80c978787a844cb53edbee33b6a90 SHA512 5a84b717de022c673c6af260381542365550f629f43ae99c7ab8b22b4c09024403a1bc06279b40d3560e86d9810683c2e8337799a4cc67ef7aeb93223b5f56a1
diff --git a/x11-themes/arc-theme/arc-theme-20221218.ebuild b/x11-themes/arc-theme/arc-theme-20221218.ebuild
new file mode 100644
index 000000000000..e1e80b8baabd
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20221218.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="A flat theme with transparent elements for GTK 2/3/4 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 +gtk4 mate +transparency xfce"
+
+GLIB_DEPEND="dev-libs/glib"
+SASSC_DEPEND="dev-lang/sassc"
+
+# Supports various GTK, GNOME Shell, and Cinnamon versions and uses
+# --version option for gnome-shell and cinnamon to determine which set of files to build.
+# Updates will therefore break existing installs but there's no way around this.
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.28
+ )
+ gtk3? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+ gtk4? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_configure() {
+ # Cinnamon still uses metacity themes for its window manager.
+ # so we enable metacity theme too if USE=cinnamon
+ # but only enable metacity if USE=mate
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon "cinnamon metacity") \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usev gtk4) \
+ $(! use cinnamon && usev mate metacity) \
+ $(usev xfce xfwm)
+ )
+
+ local emesonargs=(
+ -Dthemes="${themes%,}"
+ $(meson_use gnome-shell gnome_shell_gresource)
+ $(meson_use transparency)
+ )
+
+ meson_src_configure
+}