aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fcft/Manifest2
-rw-r--r--media-libs/fcft/fcft-3.0.0.ebuild83
-rw-r--r--media-libs/fcft/fcft-3.0.1.ebuild83
3 files changed, 168 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
index cad9ccf70..e220df336 100644
--- a/media-libs/fcft/Manifest
+++ b/media-libs/fcft/Manifest
@@ -8,3 +8,5 @@ DIST fcft-2.4.5.tar.gz 403734 BLAKE2B 3fbd0119bb1d955b0e01be4f0ab00348b0b589849e
DIST fcft-2.4.6.tar.gz 411139 BLAKE2B bbf0becd32060b74fdd0bbea09cdeb9251fdf660b63fb06c6d27b2cf7e7c088fb9a7e97ef2eb16326a139739a671fbd1ee0ae06ba026a27b16a16b37560db33f SHA512 554d4e01a24aba36eb44c195eef8b82aac08e8e32ddae3dabc45bef20428d02aee981610edecfb9f8311250b5c2c783664b0929305a857dd2910431512a91d95
DIST fcft-2.5.0.tar.gz 440068 BLAKE2B fa98eace254c2f0e04735b2f6a17bc68a94e24ad201474d3af546d385279fe275ab8a283ca0e50566879befc3bc28f7ecaef2e3aa8380d1f55999f1c0c136b66 SHA512 2bd65232ecaf10a4995051eb1409aa8e676365c7d7574e1cd6cbda73e809558572beb0c0bd7e85ee4cf946bfbc83968bef90e54fa70833ab64d70f5439de9bad
DIST fcft-2.5.1.tar.gz 440347 BLAKE2B 604e4d5cd3402bc9e2df757db8c85849ec626e2a0790de42f0e19b6ae58ee27914c4c6dceb78dfac56bd2979577e0098643e27a4a5d6c816891053657029839b SHA512 a5f8baca67bb86cd478bca768259bc162472b95407a5ee4384466d44bdb17ba4788c80465a3bf61fd23e7c9c6b1fc4adef69283250510f646539614cbbca5ab0
+DIST fcft-3.0.0.tar.gz 441458 BLAKE2B 9ff83691435953285f1b3f8b51dac7b17453a457eeb910f035e39c6fa3bb39098d3adbb7179f734261a4034e9ea8b034dd03a20ba0c364b7de2efe9b781dfdaa SHA512 fbf7ac7d777bdb530b90b79a0bd8b90d3f7ae8b099c2733304dbe89fbcc1a1a3493d1eac0478bcdee291d8c804da21461737fc3e34164637e86ff737023622b1
+DIST fcft-3.0.1.tar.gz 441493 BLAKE2B 79fe864edf04b21fe88fa167e3390836e5c7254710082312068ff4c39624508e086f4eed2ea5706b52421b2276a6f2d1f2211ff0b256112d989764e667c44fe2 SHA512 856bec504a253678a2962c0a7c5029e5fd3d26e305ca3fcae8d9df398bcc84a03e9d67522673d1f1bb0ec91606c0627d6ab4bf2780cbb5965a01c91e6f0aac89
diff --git a/media-libs/fcft/fcft-3.0.0.ebuild b/media-libs/fcft/fcft-3.0.0.ebuild
new file mode 100644
index 000000000..a3afc747c
--- /dev/null
+++ b/media-libs/fcft/fcft-3.0.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/fcft.git"
+fi
+
+DESCRIPTION="A simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+LICENSE="MIT"
+SLOT="0/3"
+IUSE="examples +text-shaping +man test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/tllist
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ text-shaping? (
+ dev-libs/libutf8proc:=
+ media-libs/harfbuzz
+ )
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ text-shaping? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ app-i18n/unicode-data
+ man? ( app-text/scdoc )
+ examples? (
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r "unicode" || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature text-shaping run-shaping)
+ $(meson_feature man docs)
+ $(meson_use examples)
+ "-Dwerror=false"
+ )
+
+ use test && emesonargs+=(
+ $(meson_use text-shaping test-text-shaping)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die "Failed to install docs"
+}
diff --git a/media-libs/fcft/fcft-3.0.1.ebuild b/media-libs/fcft/fcft-3.0.1.ebuild
new file mode 100644
index 000000000..a3afc747c
--- /dev/null
+++ b/media-libs/fcft/fcft-3.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/fcft.git"
+fi
+
+DESCRIPTION="A simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+LICENSE="MIT"
+SLOT="0/3"
+IUSE="examples +text-shaping +man test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/tllist
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ text-shaping? (
+ dev-libs/libutf8proc:=
+ media-libs/harfbuzz
+ )
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ text-shaping? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ app-i18n/unicode-data
+ man? ( app-text/scdoc )
+ examples? (
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r "unicode" || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature text-shaping run-shaping)
+ $(meson_feature man docs)
+ $(meson_use examples)
+ "-Dwerror=false"
+ )
+
+ use test && emesonargs+=(
+ $(meson_use text-shaping test-text-shaping)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die "Failed to install docs"
+}