aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-27 00:14:54 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-27 01:28:42 +0200
commitea4dbdc0e3b427eb797455dfda90e29a28d955a7 (patch)
treea671b41b4177ff47341d0b2537c9d0443ba3cc00 /sys-cluster/sionlib
parentdev-libs/properties-cpp: Forgot to take out TEST from src_prepare (diff)
downloadguru-ea4dbdc0e3b427eb797455dfda90e29a28d955a7.tar.gz
guru-ea4dbdc0e3b427eb797455dfda90e29a28d955a7.tar.bz2
guru-ea4dbdc0e3b427eb797455dfda90e29a28d955a7.zip
sys-cluster/*: split sionlibl and make them co-installable
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-cluster/sionlib')
-rw-r--r--sys-cluster/sionlib/Manifest1
-rw-r--r--sys-cluster/sionlib/metadata.xml1
-rw-r--r--sys-cluster/sionlib/sionlib-1.7.7-r1.ebuild (renamed from sys-cluster/sionlib/sionlib-1.7.7.ebuild)15
3 files changed, 10 insertions, 7 deletions
diff --git a/sys-cluster/sionlib/Manifest b/sys-cluster/sionlib/Manifest
index 8fc118f36..292998421 100644
--- a/sys-cluster/sionlib/Manifest
+++ b/sys-cluster/sionlib/Manifest
@@ -1,2 +1 @@
DIST sionlib-1.7.7.tar.gz 489080 BLAKE2B 1ffd06d1b245034b28700af1249135347cdd731a7af23ad96a27b5b5a11d64d9a67249fcd1c44cea43face1066e7ae1d59681e84cef2041e18f02e0c3e8f70ee SHA512 f270467e09893adf1af6103557365acbc9a3e73fe08716a21de6f59b25be9b187ee1c1ec1d878a9599e735f98da470b5e2e184774c27ed0ff0c330c5bf0a5677
-DIST sionlibl-1.7.7.tar.gz 490515 BLAKE2B 76971dd6d80222144b40da345d58311911aab09c6a5250b85d4a2731d2f93cdbd39d87dd6bbafdeaba88f06603105076267f6956417916f118ec45e07fa59269 SHA512 6ef46a0905552c558595bf6b72225a290d73dc87fa33c9862de5e4bd4d683792437646f7b4ab8a463b4a50d1b4a79aec96a66e577e815de3f23e9274be2681af
diff --git a/sys-cluster/sionlib/metadata.xml b/sys-cluster/sionlib/metadata.xml
index df4593cce..32002cf2d 100644
--- a/sys-cluster/sionlib/metadata.xml
+++ b/sys-cluster/sionlib/metadata.xml
@@ -30,6 +30,5 @@ SIONlib provides two different interfaces: one for parallel access (with impleme
<flag name="parutils">Enable compilation of parutils (used for benchmarking)</flag>
<flag name="pthreads">configure SIONlib to use pthreads for locking</flag>
<!--<flag name="sionfwd">enable I/O forwarding with SIONfwd</flag>-->
- <flag name="tools">Build the tooling version instead</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/sionlib/sionlib-1.7.7.ebuild b/sys-cluster/sionlib/sionlib-1.7.7-r1.ebuild
index e00956e3a..cd15e7ad6 100644
--- a/sys-cluster/sionlib/sionlib-1.7.7.ebuild
+++ b/sys-cluster/sionlib/sionlib-1.7.7-r1.ebuild
@@ -12,16 +12,13 @@ inherit docs flag-o-matic fortran-2 python-any-r1 toolchain-funcs
DESCRIPTION="Scalable I/O library for parallel access to task-local files"
HOMEPAGE="https://www.fz-juelich.de/ias/jsc/EN/Expertise/Support/Software/SIONlib/_node.html"
-SRC_URI="
- !tools? ( http://apps.fz-juelich.de/jsc/sionlib/download.php?version=${PV} -> ${P}.tar.gz )
- tools? ( http://apps.fz-juelich.de/jsc/sionlib/download.php?version=${PV}l -> ${PN}l-${PV}.tar.gz )
-"
+SRC_URI="http://apps.fz-juelich.de/jsc/sionlib/download.php?version=${PV} -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+cxx debug doc examples +fortran +mpi +ompi +openmp +parutils +pthreads python tools"
+IUSE="+cxx debug doc examples +fortran +mpi +ompi +openmp +parutils +pthreads python"
#TODO: cuda sionfwd msa
#--enable-sionfwd=/path/to/sionfwd
#--msa=(hostname-regex|deep-est-sdv)] MSA aware collective operations for the given system
@@ -103,6 +100,14 @@ src_install() {
rm -r "${T}/prefix/usr/examples" || die
fi
+ insinto "/usr/include/sionlib"
+ doins -r "${T}"/prefix/usr/include/*
+ rm -r "${T}/prefix/usr/include" || die
+
+ exeinto "/usr/libexec/${PN}"
+ doexe "${T}"/prefix/usr/bin/*partest
+ rm "${T}"/prefix/usr/bin/*partest || die
+
# move 64 bit libraries to lib64
libs64=( "${T}"/prefix/usr/lib/*64* )
if [[ ${#libs64[@]} -gt 0 ]]; then