aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Słomiński <kacper.slominski72@gmail.com>2024-11-01 00:55:43 +0100
committerKacper Słomiński <kacper.slominski72@gmail.com>2024-11-01 00:55:43 +0100
commit5f0a70373d93c709fdf117002592ca8ed0dd0e22 (patch)
tree1526da90547fc2fff5b61dd1a7932ecad1b8373a /sys-boot
parentnet-p2p/monero-gui-bin: rename file to r1 (diff)
downloadguru-5f0a70373d93c709fdf117002592ca8ed0dd0e22.tar.gz
guru-5f0a70373d93c709fdf117002592ca8ed0dd0e22.tar.bz2
guru-5f0a70373d93c709fdf117002592ca8ed0dd0e22.zip
sys-boot/limine: add 8.3.2
Signed-off-by: Kacper Słomiński <kacper.slominski72@gmail.com>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-8.3.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 20ae6a90c..6927f7b7d 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -14,3 +14,4 @@ DIST limine-8.0.7.tar.gz 553771 BLAKE2B 353ddfc22bf4609c926aa94297b7b3895727cba0
DIST limine-8.0.9.tar.gz 554003 BLAKE2B 8529d58b83fb2121412aaac3399b96166d1c93b8549514e8ac0c75429b63987b410c2aaf91388ebd2c9eb8c9a5533b9f99e273f0fcddc5f1186c2def53d510fd SHA512 79baca17ad895ae8655b9935206f065d0c89f350240cd507af0cdd14e4e71aa71e8ba45ebf368218ce7e8de4bec2fa6012b863e1ffd86fdc66c15e39663f7f80
DIST limine-8.1.1.tar.gz 557731 BLAKE2B 299923b076aa18bdf9197a55f1504424c3479f37e4b4d0ab5962c6e8ff7e1869aeca060e38ecd61e72358c0ab384ac27f1932e18db5c247b22991a0bc1c1ecd4 SHA512 8856c81f00d2167aae79b87e3b7b0bd47d5509b9950991b01176ec2ea803c3f1a9d72e3b71adecaa11554709f08241c697e5be8707fded934694585235ae1ee4
DIST limine-8.1.2.tar.gz 557929 BLAKE2B b4517ed960686f7d854f71961134a32b5cc786026ad8064a543b86f0b971eeb7c6e38a4f1560484cfc4038e1ea71fe943c0a9d37da966ce0f302c307bf59d03b SHA512 3e346bbe8d529b4bc29dfd229ca4f979e1250afefe87e6fc53db5e2af486ddffa6b7956b99aebce07e39377dd5f4dbcb3571ea022bfb86a8005c8c5ba07ecbee
+DIST limine-8.3.2.tar.gz 562262 BLAKE2B f519c2ecc2167b8fa28f4eff47e6c4e45103a42a60c374df4c28e2d2268b339997751334ca01d2a3d8d88e5d80eb4b839436104eae48ddbbd4053bbdb4703382 SHA512 16fac90b475b7bf7f7c8cb88a657a6fe960c3ecbdef9fab5283962c1c080d27fc5b417e12e855a8503f25733ada5beb3a8c336fc0d639d5172753db67ae91fec
diff --git a/sys-boot/limine/limine-8.3.2.ebuild b/sys-boot/limine/limine-8.3.2.ebuild
new file mode 100644
index 000000000..8f7c11f6a
--- /dev/null
+++ b/sys-boot/limine/limine-8.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {16..18} )
+inherit llvm-r1
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64 +uefiloong64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV LoongArch"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ $(llvm_gen_dep "
+ sys-devel/llvm:\${LLVM_SLOT}[${MY_LLVM_FLAGS}]
+ sys-devel/clang:\${LLVM_SLOT}[${MY_LLVM_FLAGS}]
+ sys-devel/lld:\${LLVM_SLOT}
+ ")
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable uefiloong64 uefi-loongarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}