aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-27 11:25:56 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-27 11:25:56 +0200
commit5a9e47d8d7d7b1ad200fccc17ca816bbdb788922 (patch)
treefeeb218e3ae363e27750b943d31ccc9e51f2ca1b /sys-apps
parentsys-fs/dwarfs: attempting to fix https://bugs.gentoo.org/785973 (diff)
downloadguru-5a9e47d8d7d7b1ad200fccc17ca816bbdb788922.tar.gz
guru-5a9e47d8d7d7b1ad200fccc17ca816bbdb788922.tar.bz2
guru-5a9e47d8d7d7b1ad200fccc17ca816bbdb788922.zip
sys-apps/0xFFFF: Set CC.
The Makefile uses $CC and initializes it with `cc`. Closes: https://bugs.gentoo.org/785157 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/0xFFFF/0xFFFF-0.8.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-apps/0xFFFF/0xFFFF-0.8.ebuild b/sys-apps/0xFFFF/0xFFFF-0.8.ebuild
index 5c3f0ac56..ea9c8a543 100644
--- a/sys-apps/0xFFFF/0xFFFF-0.8.ebuild
+++ b/sys-apps/0xFFFF/0xFFFF-0.8.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="The 0pen Free Fiasco Firmware Flasher"
HOMEPAGE="https://github.com/pali/0xFFFF/"
SRC_URI="https://github.com/pali/${PN}/releases/download/${PV}/${P}.tar.gz"
@@ -15,6 +17,11 @@ IUSE=""
DEPEND="virtual/libusb:0"
RDEPEND="${DEPEND}"
+src_compile() {
+ tc-export CC
+ default
+}
+
src_install() {
emake DESTDIR="${ED}" PREFIX="/usr" install
}