aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-11 09:59:26 +0200
committerFlorian Schmaus <flo@geekplace.eu>2021-04-11 10:00:46 +0200
commit4ee7c8fd40c19acff499fc0170fb0d59d6f7f8bb (patch)
tree4af92c74e793a71de5bf5406923c42291e28d593 /sys-apps
parentsys-power/gwe: version bump to 0.15.3 (diff)
downloadguru-4ee7c8fd40c19acff499fc0170fb0d59d6f7f8bb.tar.gz
guru-4ee7c8fd40c19acff499fc0170fb0d59d6f7f8bb.tar.bz2
guru-4ee7c8fd40c19acff499fc0170fb0d59d6f7f8bb.zip
sys-apps/dool: initial import
Bug: https://bugs.gentoo.org/781173 Signed-off-by: Florian Schmaus <flo@geekplace.eu>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dool/Manifest1
-rw-r--r--sys-apps/dool/dool-0.8_pre20191010.ebuild59
-rw-r--r--sys-apps/dool/dool-9999.ebuild59
-rw-r--r--sys-apps/dool/metadata.xml8
4 files changed, 127 insertions, 0 deletions
diff --git a/sys-apps/dool/Manifest b/sys-apps/dool/Manifest
new file mode 100644
index 000000000..5d2cd1417
--- /dev/null
+++ b/sys-apps/dool/Manifest
@@ -0,0 +1 @@
+DIST dool-0.8_pre20191010.tar.gz 141224 BLAKE2B 9c1d733b340b3f1d51798ce85698e7fc526aea349b500431d348d413c1fd93d07d8ccb8241e671a40363275b8c4025ed2f4983b4dfc70f5e166178635935337e SHA512 5204eb1c0a37b225d447830048e5f2372dd3973d50cbd3fbc42972782a4853b809e566550e752c857502f86ceed7ea31620ea27059f9f334d27f28cc61abd968
diff --git a/sys-apps/dool/dool-0.8_pre20191010.ebuild b/sys-apps/dool/dool-0.8_pre20191010.ebuild
new file mode 100644
index 000000000..ae22099fd
--- /dev/null
+++ b/sys-apps/dool/dool-0.8_pre20191010.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat (clone of dstat)"
+HOMEPAGE="https://github.com/scottchiefbaker/dool"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/scottchiefbaker/dool.git"
+ inherit git-r3
+else
+ DOOL_COMMIT_ID="6b89f2d0b6e38e1c8d706e88a12e020367f5100d"
+ SRC_URI="https://github.com/scottchiefbaker/dool/archive/${DOOL_COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${DOOL_COMMIT_ID}"
+fi
+
+if [[ "${PV}" != "9999" ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+
+ insinto "/usr/share/${PN}"
+ newins "${PN}" "${PN}.py"
+ doins plugins/${PN}_*.py
+
+ doman "docs/${PN}.1"
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}
+
+src_test() {
+ python_foreach_impl emake test
+}
diff --git a/sys-apps/dool/dool-9999.ebuild b/sys-apps/dool/dool-9999.ebuild
new file mode 100644
index 000000000..ae22099fd
--- /dev/null
+++ b/sys-apps/dool/dool-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat (clone of dstat)"
+HOMEPAGE="https://github.com/scottchiefbaker/dool"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/scottchiefbaker/dool.git"
+ inherit git-r3
+else
+ DOOL_COMMIT_ID="6b89f2d0b6e38e1c8d706e88a12e020367f5100d"
+ SRC_URI="https://github.com/scottchiefbaker/dool/archive/${DOOL_COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${DOOL_COMMIT_ID}"
+fi
+
+if [[ "${PV}" != "9999" ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+
+ insinto "/usr/share/${PN}"
+ newins "${PN}" "${PN}.py"
+ doins plugins/${PN}_*.py
+
+ doman "docs/${PN}.1"
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}
+
+src_test() {
+ python_foreach_impl emake test
+}
diff --git a/sys-apps/dool/metadata.xml b/sys-apps/dool/metadata.xml
new file mode 100644
index 000000000..bdf5f6f4f
--- /dev/null
+++ b/sys-apps/dool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type='person'>
+ <email>flo@geekplace.eu</email>
+ <name>Florian Schmaus</name>
+ </maintainer>
+</pkgmetadata>