aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-29 00:53:18 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-29 00:53:18 +0900
commit18bcbdffa6509f097fd129659706e7036f20caa0 (patch)
treec2fd5ca1282abbd2087b9b947a0bcce5f9269c75 /dev-ml
parentdev-python/pillow-heif: drop 0.15.0 (diff)
downloadguru-18bcbdffa6509f097fd129659706e7036f20caa0.tar.gz
guru-18bcbdffa6509f097fd129659706e7036f20caa0.tar.bz2
guru-18bcbdffa6509f097fd129659706e7036f20caa0.zip
dev-ml/ocamlformat-rpc-lib: new package, add 0.26.2
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlformat-rpc-lib/Manifest1
-rw-r--r--dev-ml/ocamlformat-rpc-lib/metadata.xml13
-rw-r--r--dev-ml/ocamlformat-rpc-lib/ocamlformat-rpc-lib-0.26.2.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ocamlformat-rpc-lib/Manifest b/dev-ml/ocamlformat-rpc-lib/Manifest
new file mode 100644
index 000000000..1b3a2aa44
--- /dev/null
+++ b/dev-ml/ocamlformat-rpc-lib/Manifest
@@ -0,0 +1 @@
+DIST ocamlformat-rpc-lib-0.26.2.tar.gz 901463 BLAKE2B 619838f68f6031d8e98319a66c3a906b46e1c394c5d7ddce18a4c91029522add716f298d18b232503a84c1a0f6384edd280cc20faf0974f5b8c019e2e827a083 SHA512 c6df074b69a35a545898961f8cd578a5cafbf4a382bd0b9783a770a40072bdd91be864a53c27c175ceef7ffff5a25b165b475c7a92ac4f790bf19abc74897bbe
diff --git a/dev-ml/ocamlformat-rpc-lib/metadata.xml b/dev-ml/ocamlformat-rpc-lib/metadata.xml
new file mode 100644
index 000000000..446b3e4f2
--- /dev/null
+++ b/dev-ml/ocamlformat-rpc-lib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <name>Hiroki Tokunaga</name>
+ </maintainer>
+ <longdescription lang="en">OCamlFormat is a tool to automatically format OCaml code in a uniform style. This package defines a RPC interface to OCamlFormat.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-ppx/ocamlformat/issues</bugs-to>
+ <remote-id type="github">ocaml-ppx/ocamlformat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlformat-rpc-lib/ocamlformat-rpc-lib-0.26.2.ebuild b/dev-ml/ocamlformat-rpc-lib/ocamlformat-rpc-lib-0.26.2.ebuild
new file mode 100644
index 000000000..9f5a24ff4
--- /dev/null
+++ b/dev-ml/ocamlformat-rpc-lib/ocamlformat-rpc-lib-0.26.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Auto-formatter for OCaml code (RPC mode)"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/ocamlformat-rpc-lib
+ https://github.com/ocaml-ppx/ocamlformat
+"
+SRC_URI="https://github.com/ocaml-ppx/ocamlformat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/ocamlformat-${PV}"
+
+LICENSE="MIT"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/csexp-1.4.0:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_compile() {
+ dune-compile ocamlformat-rpc-lib
+}
+
+src_install() {
+ dune-install ocamlformat-rpc-lib
+}