aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-30 14:29:28 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-30 14:30:15 +0200
commit7ebb36b5a2dccad1459432fb7635ce7a9905c800 (patch)
tree385fe595426270bd5386dafb503d40cae1c6c368 /app-misc
parentapp-text/cmark-gfm: initial import (diff)
downloadguru-7ebb36b5a2dccad1459432fb7635ce7a9905c800.tar.gz
guru-7ebb36b5a2dccad1459432fb7635ce7a9905c800.tar.bz2
guru-7ebb36b5a2dccad1459432fb7635ce7a9905c800.zip
app-misc/nonsense: workaround with a wrapper
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/nonsense/files/nonsense.sh4
-rw-r--r--app-misc/nonsense/nonsense-0.7-r1.ebuild24
2 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/nonsense/files/nonsense.sh b/app-misc/nonsense/files/nonsense.sh
new file mode 100644
index 000000000..45707ce36
--- /dev/null
+++ b/app-misc/nonsense/files/nonsense.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nonsense
+exec perl /usr/share/nonsense/nonsense.pl "$@"
diff --git a/app-misc/nonsense/nonsense-0.7-r1.ebuild b/app-misc/nonsense/nonsense-0.7-r1.ebuild
new file mode 100644
index 000000000..829f3a0d3
--- /dev/null
+++ b/app-misc/nonsense/nonsense-0.7-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="766d34590e1fc0edddb381ad16fab57f5d20d299"
+
+DESCRIPTION="Generates random text from datafiles and templates"
+HOMEPAGE="
+ https://github.com/aduial/nonsense
+ https://nonsense.sourceforge.net
+"
+SRC_URI="https://github.com/aduial/nonsense/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_install() {
+ newbin "${FILESDIR}/nonsense.sh" nonsense
+ dodoc README.md CHANGELOG.md HOWTO.md
+ insinto /usr/share/nonsense
+ doins *.data *.html *.template nonsense.pl
+}