summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2011-04-10 09:42:03 +1200
committerAlistair Bush <ali_bush@gentoo.org>2011-04-10 09:42:03 +1200
commit81b7cc185d8be672603a00c071ac499edfb97916 (patch)
treeb2f806851b14bdd74c0511a9ed3c471a7174a550
parentIn tree (diff)
downloaddotnet-81b7cc185d8be672603a00c071ac499edfb97916.tar.gz
dotnet-81b7cc185d8be672603a00c071ac499edfb97916.tar.bz2
dotnet-81b7cc185d8be672603a00c071ac499edfb97916.zip
New package commonservicelocator.
-rw-r--r--dev-dotnet/commonservicelocator/ChangeLog12
-rw-r--r--dev-dotnet/commonservicelocator/Manifest5
-rw-r--r--dev-dotnet/commonservicelocator/commonservicelocator-1.0.ebuild56
-rw-r--r--dev-dotnet/commonservicelocator/files/commonservicelocator-1.0-signing.patch19
-rw-r--r--dev-dotnet/commonservicelocator/files/commonservicelocator.pc.in8
-rw-r--r--dev-dotnet/commonservicelocator/files/commonservicelocator.snkbin0 -> 596 bytes
6 files changed, 100 insertions, 0 deletions
diff --git a/dev-dotnet/commonservicelocator/ChangeLog b/dev-dotnet/commonservicelocator/ChangeLog
new file mode 100644
index 0000000..63bd474
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-dotnet/commonservicelocator
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*commonservicelocator-1.0 (09 Apr 2011)
+
+ 09 Apr 2011; Alistair Bush <ali_bush@gentoo.org>
+ +commonservicelocator-1.0.ebuild,
+ +files/commonservicelocator-1.0-signing.patch,
+ +files/commonservicelocator.pc.in, +files/commonservicelocator.snk:
+ Package commonservicelocator.
+
diff --git a/dev-dotnet/commonservicelocator/Manifest b/dev-dotnet/commonservicelocator/Manifest
new file mode 100644
index 0000000..7063699
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/Manifest
@@ -0,0 +1,5 @@
+AUX commonservicelocator-1.0-signing.patch 1048 RMD160 8c01c078423b98ff0783869e35bac3c50c20e69f SHA1 064ebe3d983ecc5f9ae85ced5a43b562962fd8f1 SHA256 d3f5c944215b158f68b7a8bb407654d559e946b1ee15574da4f69efde9cab2ab
+AUX commonservicelocator.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
+AUX commonservicelocator.snk 596 RMD160 a9134f0644e039e04d1188fce1a959a1c216a0fa SHA1 55d1bda3146c5aafbff7e3ff6f43d634af9c626b SHA256 6ce5c610218f98c6220c6a1483e6b75ed05d48a39ed6aa749b26547b94129913
+DIST commonservicelocator-1.0.zip 16878 RMD160 58acc508b863f48671a56a5daf0f31479681a622 SHA1 1ca9e0f9d518d065fdac13eef7b4245f6b5e871b SHA256 6da0ef1ceca4a26f1cfc0540e2ca5964202314fb71cbaac6d0b27a4b414cf2c4
+EBUILD commonservicelocator-1.0.ebuild 1470 RMD160 8e64e26a118de4e3bf60d410e120a95a498a5df3 SHA1 7ec3d9b3496868b9b5a0e59c0b3284767e48d098 SHA256 7d1158e0fdfe4c46f52ed56202c0a3dcbd8676d65919fc87f2fb51bed05f68a6
diff --git a/dev-dotnet/commonservicelocator/commonservicelocator-1.0.ebuild b/dev-dotnet/commonservicelocator/commonservicelocator-1.0.ebuild
new file mode 100644
index 0000000..b7c1c2d
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/commonservicelocator-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit base mono
+
+DESCRIPTION="An abstraction over IoC containers and service locators."
+HOMEPAGE="http://commonservicelocator.codeplex.com/"
+
+#Not sure whether having this 'direct' url is legal.
+SRC_URI="http://download.codeplex.com/Project/Download/SourceControlFileDownload.ashx?ProjectName=commonservicelocator&changeSetId=24262 -> ${P}.zip"
+
+LICENSE="Ms-PL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/mono"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/main"
+
+PATCHES="${FILESDIR}/${P}-signing.patch"
+
+src_prepare() {
+ base_src_prepare
+ cp ${FILESDIR}/${PN}.snk . || die
+}
+
+src_compile()
+{
+ xbuild Microsoft.Practices.ServiceLocation.sln
+}
+
+_DLL_LOCATION="Microsoft.Practices.ServiceLocation/bin/Debug"
+_DLL_NAME="Microsoft.Practices.ServiceLocation.dll"
+
+src_install() {
+ pushd ${_DLL_LOCATION} &> /dev/null
+ egacinstall ${_DLL_NAME}
+ popd &> /dev/null
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/commonservicelocator/Microsoft.Practices.ServiceLocation.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists ${PN} || die ".pc file failed to validate."
+ eend $?
+
+}
diff --git a/dev-dotnet/commonservicelocator/files/commonservicelocator-1.0-signing.patch b/dev-dotnet/commonservicelocator/files/commonservicelocator-1.0-signing.patch
new file mode 100644
index 0000000..71fbd1d
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/files/commonservicelocator-1.0-signing.patch
@@ -0,0 +1,19 @@
+diff -Naur main-bak/Microsoft.Practices.ServiceLocation/Microsoft.Practices.ServiceLocation.csproj main/Microsoft.Practices.ServiceLocation/Microsoft.Practices.ServiceLocation.csproj
+--- main-bak/Microsoft.Practices.ServiceLocation/Microsoft.Practices.ServiceLocation.csproj 2011-04-09 14:32:24.000000000 +1200
++++ main/Microsoft.Practices.ServiceLocation/Microsoft.Practices.ServiceLocation.csproj 2011-04-09 14:40:32.000000000 +1200
+@@ -9,6 +9,8 @@
+ <AppDesignerFolder>Properties</AppDesignerFolder>
+ <RootNamespace>Microsoft.Practices.ServiceLocation</RootNamespace>
+ <AssemblyName>Microsoft.Practices.ServiceLocation</AssemblyName>
++ <SignAssembly>true</SignAssembly>
++ <AssemblyOriginatorKeyFile>..\commonservicelocator.snk</AssemblyOriginatorKeyFile>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
+ <DebugSymbols>true</DebugSymbols>
+@@ -66,4 +68,4 @@
+ <Target Name="AfterBuild">
+ </Target>
+ -->
+-</Project>
+\ No newline at end of file
++</Project>
diff --git a/dev-dotnet/commonservicelocator/files/commonservicelocator.pc.in b/dev-dotnet/commonservicelocator/files/commonservicelocator.pc.in
new file mode 100644
index 0000000..33d48a8
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/files/commonservicelocator.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/commonservicelocator/files/commonservicelocator.snk b/dev-dotnet/commonservicelocator/files/commonservicelocator.snk
new file mode 100644
index 0000000..7c1bd5b
--- /dev/null
+++ b/dev-dotnet/commonservicelocator/files/commonservicelocator.snk
Binary files differ