aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:07:38 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:07:38 -0700
commit928cec86b0a283232593b4313fccd997e48deaca (patch)
treef67db4964597ada6f450762188f3c5c5d5081e11 /media-libs
parentbone-sources update (diff)
downloadarm-928cec86b0a283232593b4313fccd997e48deaca.tar.gz
arm-928cec86b0a283232593b4313fccd997e48deaca.tar.bz2
arm-928cec86b0a283232593b4313fccd997e48deaca.zip
new git ebuild for latest upstream libgrate
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/grate/Manifest2
-rw-r--r--media-libs/grate/files/grate-implicit_declaration.patch12
-rw-r--r--media-libs/grate/grate-9999.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/grate/Manifest b/media-libs/grate/Manifest
new file mode 100644
index 0000000..7cef92d
--- /dev/null
+++ b/media-libs/grate/Manifest
@@ -0,0 +1,2 @@
+AUX grate-implicit_declaration.patch 301 SHA256 a554986d7baa2d40902ec006cc2dabd9e8d3178ae1f6e205368fe5b3572d021d SHA512 bc5c0932610f1becabc8d6a67f032e188c28b263f95a5a6b6a78b05eeb3c2a0b696c864733f348bb0e23afe1e68539ad07e40b8fd42e1bd79a97488df0019a8e WHIRLPOOL 20a43aaefd0771c9c100022b3c4ea9a2992447ce4ae79443280eaae36c83ffe06eb78010aacaf5bc030524b1758a63aa89980eb018746eeb9b48ece493386e95
+EBUILD grate-9999.ebuild 833 SHA256 352d1bd05a055c750fc3ef3238bb7c06c87988f430b385742e29bf0ab51f0337 SHA512 bdd2dfaebbbec445e078b551c4ccd74f32a5d1388662cd62c19f7a2f310ed6ff1f91e9174699c4c54491342fef027d9cb4d51518df43f712fc93a6acae9bbc4b WHIRLPOOL 9d7724acbfb6b8e1c621f1ac8563949351c5ee4295dbea9d9b87d24cb886096dff6702fb5a88abebfff0b16263a3f86e42d4265a86d3ee39d87ad31c36d6fbb0
diff --git a/media-libs/grate/files/grate-implicit_declaration.patch b/media-libs/grate/files/grate-implicit_declaration.patch
new file mode 100644
index 0000000..5f9bf85
--- /dev/null
+++ b/media-libs/grate/files/grate-implicit_declaration.patch
@@ -0,0 +1,12 @@
+diff --git a/src/libhost1x/host1x-framebuffer.c b/src/libhost1x/host1x-framebuffer.c
+index 9258eb4..77c3d42 100644
+--- a/src/libhost1x/host1x-framebuffer.c
++++ b/src/libhost1x/host1x-framebuffer.c
+@@ -23,6 +23,7 @@
+
+ #include <errno.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include <png.h>
+
diff --git a/media-libs/grate/grate-9999.ebuild b/media-libs/grate/grate-9999.ebuild
new file mode 100644
index 0000000..ad034fb
--- /dev/null
+++ b/media-libs/grate/grate-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="https://github.com/grate-driver/grate.git"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils git-2
+
+DESCRIPTION="Grate: open source Tegra 2D/3D user-space libraries"
+HOMEPAGE="https://github.com/grate-driver"
+
+KEYWORDS="~arm ~arm-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ media-libs/libpng
+ media-libs/mesa[egl,gles1,gles2]
+ x11-proto/xproto
+ x11-libs/libdrm
+ !sys-apps/tcp-wrappers"
+
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}/${PN}-implicit_declaration.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-pic
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+}
+