summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/stunnel/stunnel-3.26.ebuild')
-rw-r--r--net-misc/stunnel/stunnel-3.26.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/net-misc/stunnel/stunnel-3.26.ebuild b/net-misc/stunnel/stunnel-3.26.ebuild
index 4e6c1427895c..98632a4f8c29 100644
--- a/net-misc/stunnel/stunnel-3.26.ebuild
+++ b/net-misc/stunnel/stunnel-3.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.26.ebuild,v 1.8 2004/07/28 20:35:26 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.26.ebuild,v 1.9 2004/10/14 14:32:48 usata Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc alpha ppc ~amd64"
+KEYWORDS="x86 sparc alpha ppc ~amd64 ~ppc-macos"
IUSE=""
RDEPEND=">=dev-libs/openssl-0.9.6j"
@@ -21,6 +21,11 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
+ if use ppc-macos ; then
+ sed -i -e "s,-shared,-dynamic -flat_namespace -bundle -undefined suppress,g" \
+ -e "s,stunnel.so,stunnel.dylib,g" \
+ Makefile.in || die "sed failed"
+ fi
}
src_compile() {
@@ -32,5 +37,9 @@ src_install() {
dosbin stunnel
dodoc FAQ README HISTORY COPYING BUGS PORTS TODO transproxy.txt
doman stunnel.8
- dolib.so stunnel.so
+ if use ppc-macos ; then
+ dolib.so stunnel.dylib
+ else
+ dolib.so stunnel.so
+ fi
}