summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jhead/jhead-2.90.ebuild')
-rw-r--r--media-gfx/jhead/jhead-2.90.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-2.90.ebuild b/media-gfx/jhead/jhead-2.90.ebuild
new file mode 100644
index 000000000000..e84930092a95
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.90.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.90.ebuild,v 1.1 2011/02/12 16:48:33 vanquirius Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_unpack() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV}-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}