summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.4.7.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 140c00e412f5..b388501d9ca2 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.19 2010/09/11 05:50:52 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.20 2010/10/24 16:20:46 tampakrap Exp $
+
+*kdepim-runtime-4.4.7 (24 Oct 2010)
+
+ 24 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdepim-runtime-4.4.7.ebuild:
+ Version bump KDEPIM 4.4.7
*kdepim-runtime-4.4.6 (11 Sep 2010)
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.4.7.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.4.7.ebuild
new file mode 100644
index 000000000000..4bb2e25cb8a5
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.4.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.4.7.ebuild,v 1.1 2010/10/24 16:20:46 tampakrap Exp $
+
+EAPI="3"
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ KMMODULE="runtime"
+ inherit kde4-meta
+else
+ inherit kde4-base
+fi
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.3.1
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+"
+
+add_blocker akonadi '<4.3.90'