summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/opengfx/opengfx-0.4.4.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.4.4.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-misc/opengfx/opengfx-0.4.4.ebuild b/games-misc/opengfx/opengfx-0.4.4.ebuild
index ef834daaa142..480cdac0c8dd 100644
--- a/games-misc/opengfx/opengfx-0.4.4.ebuild
+++ b/games-misc/opengfx/opengfx-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.4 2012/04/18 20:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.5 2012/04/19 07:25:01 scarabeus Exp $
EAPI=3
inherit games
@@ -14,20 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=games-util/nml-0.2.3
- media-gfx/gimp"
+DEPEND=">=games-util/nml-0.2.3"
RDEPEND=""
S=${WORKDIR}/${P}-source
src_prepare() {
sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ sed -i \
+ -e 's:echo "gimp":echo "":g' \
+ scripts/Makefile.def || die
}
src_compile() {
- GIMP2_DIRECTORY="${T}" \
- GEGL_PATH="${T}" \
- GEGL_SWAP="${T}" \
emake bundle || die
}