summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/memonix/ChangeLog11
-rw-r--r--games-kids/memonix/Manifest4
-rw-r--r--games-kids/memonix/memonix-1.6.ebuild48
-rw-r--r--games-kids/memonix/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/games-kids/memonix/ChangeLog b/games-kids/memonix/ChangeLog
new file mode 100644
index 000000000000..f344d39ad67d
--- /dev/null
+++ b/games-kids/memonix/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-kids/memonix
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/memonix/ChangeLog,v 1.1 2012/11/17 07:56:14 mr_bones_ Exp $
+
+*memonix-1.6 (17 Nov 2012)
+
+ 17 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +memonix-1.6.ebuild,
+ +metadata.xml:
+ initial commit with modified ebuild submitted by Vicente Olivert Riera (bug
+ #436552)
+
diff --git a/games-kids/memonix/Manifest b/games-kids/memonix/Manifest
new file mode 100644
index 000000000000..926be50c4370
--- /dev/null
+++ b/games-kids/memonix/Manifest
@@ -0,0 +1,4 @@
+DIST memonix_1.6_src.tar.bz2 6949315 SHA256 c5bd236c5cff2ffc07d98aff698368f32149c2428229fcde913e93bced250eab SHA512 212def9c30cd878103d4ac8b7f57c5fcaeffa74ee7ece18a993c69304de94a2ce9eea24a70af394477532ac9a0887b595e220e106239cac5e6aec5a75d1a8ff1 WHIRLPOOL 723a624ef298b0863d76fe0d53545e11b88ef9020ea3d7168c2b9673f39f1779e390f8f6ab9d3b2a0ac4123ce72e92e1ccb6b814d7f5b98347bb5af84fa1d919
+EBUILD memonix-1.6.ebuild 1093 SHA256 54f12759db8c8994c7b8c6855a287125f9a95c944791917430062507f406b72b SHA512 37ccb68e55083d0305edc8ad8c7d9475140419625911f526164422fa96d91e73e023a870dfb7eeb69eca9b8e18e3a85dbd1f674936e6d4e343d5a4c815ae6daa WHIRLPOOL c6a7e42ccc4baa115fe55ff48976107410c0c82c28fa13f152f15b3239c690c0cd898b212c29fae3032eb747a7fbdb0c05f59632964eb7a8877ca4a02afa0258
+MISC ChangeLog 423 SHA256 8b1aa3112a62c81b419ab001ff0d2397204cc3432631178365d2fb3fd45bd006 SHA512 4c86be5d35ba2fefbad8ebbc2b421f080189c075c67520103dc74ff16c9a77887f5502914138db7ec046402e5cbb20b1d1aa20382f25ba5f0d91bafde9c2cf2b WHIRLPOOL 5dd8604f3b5cd100f7a353302f97203be7ac60dc21e8ae9dd5e4145fa126e36d08753ae95b597c0e51457ee6ab4e576d7b0c1b5992681a7ea1c39bad292e7fb6
+MISC metadata.xml 158 SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3 SHA512 d954564236b67b6ab97846b73f74e715e8f1bec2dba6595e9a5046c2e8c3b93f4879c293f9d1d02d99a533bee56156dae3f31a485697128c51af14cdbfdada8a WHIRLPOOL d03e7293d09d794d61c095a423f945b3644355a247f270a73ca8d30b4dfe9c98244297536bfd1a4bd6c14794aa1152eca20fd83bfdf3e1e74d4f676152d35ada
diff --git a/games-kids/memonix/memonix-1.6.ebuild b/games-kids/memonix/memonix-1.6.ebuild
new file mode 100644
index 000000000000..4a899165ae95
--- /dev/null
+++ b/games-kids/memonix/memonix-1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/memonix/memonix-1.6.ebuild,v 1.1 2012/11/17 07:56:14 mr_bones_ Exp $
+
+EAPI=4
+inherit cmake-utils games
+
+DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
+HOMEPAGE="http://www.viewizard.com/memonix/"
+SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="Memonix"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[audio,opengl,video]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[vorbis]
+ !games-kids/memonix-bin"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/MemonixSourceCode
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)"
+ doexe ../${P}_build/Memonix
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../gamedata.vfs
+
+ games_make_wrapper ${PN} "$(games_get_libdir)"/Memonix "${GAMES_DATADIR}"/${PN}
+
+ newicon ../icon48.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dodoc ReadMe.txt
+
+ prepgamesdirs
+}
diff --git a/games-kids/memonix/metadata.xml b/games-kids/memonix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-kids/memonix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>