summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/atari800/atari800-2.0.2.ebuild98
-rw-r--r--games-emulation/emutos/emutos-0.8.2.ebuild27
-rw-r--r--games-emulation/gcube/gcube-0.4.ebuild40
-rw-r--r--games-emulation/hatari/hatari-0.95.ebuild53
-rw-r--r--games-emulation/mamory/mamory-0.2.23.ebuild54
-rw-r--r--games-emulation/mednafen/mednafen-0.6.1.ebuild54
-rw-r--r--games-emulation/stella/stella-2.2.ebuild48
7 files changed, 0 insertions, 374 deletions
diff --git a/games-emulation/atari800/atari800-2.0.2.ebuild b/games-emulation/atari800/atari800-2.0.2.ebuild
deleted file mode 100644
index bef5d8368998..000000000000
--- a/games-emulation/atari800/atari800-2.0.2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-2.0.2.ebuild,v 1.6 2006/12/01 22:13:34 wolf31o2 Exp $
-
-inherit games
-
-DESCRIPTION="Atari 800 emulator"
-HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/xf25.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ppc sparc x86"
-IUSE="sdl"
-
-RDEPEND="sdl? ( >=media-libs/libsdl-1.2.0 )
- !sdl? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- !sdl? (
- x11-libs/libXt
- x11-libs/libX11
- x11-proto/xextproto
- x11-proto/xproto )
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove some not-so-interesting ones
- rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
- sed -i "/CFG_FILE/s:/etc:${GAMES_SYSCONFDIR}:" \
- src/atari.c || die "sed failed"
-}
-
-src_compile() {
- local target="x11"
- use sdl && target="sdl"
-
- cd src && \
- egamesconf \
- --enable-crashmenu \
- --enable-break \
- --enable-hints \
- --enable-asm \
- --enable-cursorblk \
- --enable-led \
- --enable-displayled \
- --enable-sndclip \
- --enable-linuxjoy \
- --enable-sound \
- --target=${target} \
- || die
- emake || die "emake failed"
-}
-
-src_install () {
- dogamesbin src/atari800 || die "dogamesbin failed"
- newman src/atari800.man atari800.6
- dodoc README.1ST DOC/*
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- sed "s:/usr/share/games:${GAMES_DATADIR}:" \
- "${FILESDIR}"/atari800.cfg > "${T}"/atari800.cfg \
- || die "sed failed"
- insinto "${GAMES_SYSCONFDIR}"
- doins "${T}"/atari800.cfg || die "doins failed (cfg)"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use sdl ; then
- echo
- elog 'The emulator has been compiled using the SDL libraries. By default,'
- elog 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- elog 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- elog 'screen is postage-stamp sized in the middle of your display.'
- echo
- elog 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- elog 'add the entry "400x300" to the end of the list of modes:'
- echo
- elog ' Section "Screen"'
- elog ' [...]'
- elog
- elog ' Subsection "Display"'
- elog ' Depth 16'
- elog ' Modes "1600x1200" "1024x768" "400x300"'
- elog ' ViewPort 0 0'
- elog ' EndSubsection'
- elog ' EndSection'
- echo
- elog 'You should not need to specify a modeline for this mode,'
- elog 'since in most cases it is a standard mode calculated by'
- elog 'the X server.'
- echo
- fi
-}
diff --git a/games-emulation/emutos/emutos-0.8.2.ebuild b/games-emulation/emutos/emutos-0.8.2.ebuild
deleted file mode 100644
index 813c68fda236..000000000000
--- a/games-emulation/emutos/emutos-0.8.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/emutos/emutos-0.8.2.ebuild,v 1.3 2008/02/14 22:46:37 nyhm Exp $
-
-inherit games
-
-DESCRIPTION="a single-user single-tasking operating system for 32 bit Atari computer emulators"
-HOMEPAGE="http://emutos.sourceforge.net"
-SRC_URI="mirror://sourceforge/emutos/emutos-512k-${PV}.zip
- mirror://sourceforge/emutos/emutos-256k-${PV}.zip
- mirror://sourceforge/emutos/emutos-192k-${PV}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="app-arch/unzip"
-
-S=${WORKDIR}
-
-src_install() {
- dogameslib */*.img || die "dogameslib failed"
- dodoc emutos-512k-${PV}/{readme.txt,doc/{announce,authors,changelog,status}.txt}
- prepgamesdirs
-}
diff --git a/games-emulation/gcube/gcube-0.4.ebuild b/games-emulation/gcube/gcube-0.4.ebuild
deleted file mode 100644
index ce4f56d1c9f6..000000000000
--- a/games-emulation/gcube/gcube-0.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/gcube-0.4.ebuild,v 1.2 2006/05/05 19:11:05 squinky86 Exp $
-
-inherit games
-
-DESCRIPTION="Gamecube emulator"
-HOMEPAGE="http://gcube.exemu.net/"
-SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-
-DEPEND="virtual/opengl
- media-libs/libsdl
- sys-libs/ncurses
- sys-libs/zlib"
-
-S=${WORKDIR}/${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CFLAGS=-g/d' Makefile.rules \
- || die "sed failed"
-}
-
-src_install() {
- local x
-
- dogamesbin gcmap gcube || die "dogamesbin failed"
- for x in bin2dol isopack tplx ; do
- newgamesbin ${x} ${PN}-${x} || die "newgamesbin failed"
- done
- dodoc ChangeLog README
- prepgamesdirs
-}
diff --git a/games-emulation/hatari/hatari-0.95.ebuild b/games-emulation/hatari/hatari-0.95.ebuild
deleted file mode 100644
index bb88333d6576..000000000000
--- a/games-emulation/hatari/hatari-0.95.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.95.ebuild,v 1.2 2007/12/04 02:20:12 mr_bones_ Exp $
-
-inherit games
-
-DESCRIPTION="Atari ST emulator"
-HOMEPAGE="http://hatari.sourceforge.net/"
-SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl
- sys-libs/readline
- sys-libs/zlib"
-RDEPEND="${DEPEND}
- games-emulation/emutos"
-
-src_compile() {
- egamesconf || die
- # broken deps in the makefiles - bug #164068
- emake -C src/uae-cpu gencpu || die "emake failed"
- emake -C src/uae-cpu all || die "emake failed"
- emake -C src || die "emake failed"
-}
-
-src_install() {
- dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
- || die "doins failed"
- dodoc readme.txt doc/*.txt
- dohtml -r doc/
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
- elog "has been installed in $(games_get_libdir) with a .img extension (there"
- elog "are several from which to choose)."
- elog
- elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
- elog " http://www.atari.st/"
- elog
- elog "The first time you run hatari, you should configure it to find the"
- elog "TOS you prefer to use. Be sure to save your settings."
- echo
-}
diff --git a/games-emulation/mamory/mamory-0.2.23.ebuild b/games-emulation/mamory/mamory-0.2.23.ebuild
deleted file mode 100644
index de8018bc2189..000000000000
--- a/games-emulation/mamory/mamory-0.2.23.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.23.ebuild,v 1.2 2007/07/02 21:25:34 nyhm Exp $
-
-inherit autotools games
-
-DESCRIPTION="ROM management tools and library"
-HOMEPAGE="http://mamory.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-DEPEND="dev-libs/expat"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Make sure the system expat is used
- sed -i \
- -e 's/#ifdef.*SYSEXPAT/#if 1/' \
- mamory/amlxml.c mamory/amlxml.h \
- || die "sed amlxml failed"
-
- # Remove hardcoded CFLAGS options
- sed -i \
- -e '/AC_ARG_ENABLE(debug,/ {N;N;N;d}' \
- configure.ac \
- || die "sed configure.ac failed"
-
- # Make it possible for eautoreconf to fix fPIC etc.
- sed -i \
- -e '/libcommon_la_LDFLAGS= -static/d' \
- common/Makefile.am \
- || die "sed Makefile.am failed"
-
- AT_M4DIR="config" eautoreconf || die
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- --includedir=/usr/include || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README TODO
- dohtml DOCS/mamory.html
- prepgamesdirs
-}
diff --git a/games-emulation/mednafen/mednafen-0.6.1.ebuild b/games-emulation/mednafen/mednafen-0.6.1.ebuild
deleted file mode 100644
index 16c9fad95d37..000000000000
--- a/games-emulation/mednafen/mednafen-0.6.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.6.1.ebuild,v 1.7 2007/11/14 16:49:56 mr_bones_ Exp $
-
-inherit games
-
-DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, and Lynx emulator"
-HOMEPAGE="http://mednafen.sourceforge.net/"
-SRC_URI="http://mednafen.com/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND="virtual/opengl
- sys-libs/zlib
- media-libs/libsndfile
- dev-libs/libcdio
- >=media-libs/libsdl-1.2.0
- media-libs/sdl-net"
-
-# The following likely still applies to Mednafen as it uses FCE Ultra code.
-# Because of code generation bugs, FCEUltra now depends on a version
-# of gcc greater than or equal to GCC 3.2.2.
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-3.2.2"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's:\$(datadir)/locale:/usr/share/locale:' \
- po/Makefile.in.in \
- intl/Makefile.in \
- src/Makefile.in \
- || die "sed failed"
-}
-
-# v0.5.2 conf with --disable-nls fails to compile
-src_compile() {
- egamesconf \
- --disable-dependency-tracking || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS README NEWS TODO ChangeLog
- dohtml Documentation/*
- prepgamesdirs
-}
diff --git a/games-emulation/stella/stella-2.2.ebuild b/games-emulation/stella/stella-2.2.ebuild
deleted file mode 100644
index 3238ab7470bf..000000000000
--- a/games-emulation/stella/stella-2.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.2.ebuild,v 1.3 2008/02/29 19:05:53 carlo Exp $
-
-inherit eutils games
-
-DESCRIPTION="Stella Atari 2600 VCS Emulator"
-HOMEPAGE="http://stella.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="opengl"
-
-DEPEND="media-libs/libsdl
- media-libs/libpng
- opengl? ( virtual/opengl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/INSTALL/s/-s //' \
- -e '/strip/d' \
- -e "/icons/d" \
- Makefile \
- || die "sed failed"
-}
-
-src_compile() {
- # not an autoconf script
- ./configure \
- --prefix="/usr" \
- --bindir="${GAMES_BINDIR}" \
- --docdir="/usr/share/doc/${PF}" \
- --datadir="${GAMES_DATADIR}" \
- $(use_enable opengl) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- doicon src/common/stella.xpm
- make_desktop_entry stella Stella stella
- prepgamesdirs
-}