summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/Manifest4
-rw-r--r--dev-python/pygame/files/digest-pygame-1.5.61
-rw-r--r--dev-python/pygame/pygame-1.5.6.ebuild35
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pygame/Manifest b/dev-python/pygame/Manifest
index 0df7ca296459..1bc568926e0d 100644
--- a/dev-python/pygame/Manifest
+++ b/dev-python/pygame/Manifest
@@ -1,7 +1,7 @@
-MD5 d86869cfb8fb0f1bb9982ba861512727 ChangeLog 1958
+MD5 b495796d42cefedbdc4a57403c5d341c ChangeLog 2088
MD5 ca4a36af23bff0768dc77811c250dcc2 pygame-1.5.3.ebuild 855
MD5 36b0e4a34427ea98ca0082ffdc38b17a pygame-1.5.5.ebuild 917
-MD5 441cdde01ad5f044b5f573c1bec0afaf pygame-1.5.6.ebuild 923
+MD5 b4e12c19a7a983d079606c0ec370e709 pygame-1.5.6.ebuild 924
MD5 bcc21545f0d3a09c4bf9beb344d39535 files/digest-pygame-1.5.3 64
MD5 a0a1443e65c63b895d64a478953de7c7 files/digest-pygame-1.5.5 64
MD5 8f157ac063bfbc2817a2ee8d2acf05c7 files/mixer.c-pause.patch 812
diff --git a/dev-python/pygame/files/digest-pygame-1.5.6 b/dev-python/pygame/files/digest-pygame-1.5.6
new file mode 100644
index 000000000000..7dc024445721
--- /dev/null
+++ b/dev-python/pygame/files/digest-pygame-1.5.6
@@ -0,0 +1 @@
+MD5 d5ed5a18f463d898d590b77ea4ea9e00 pygame-1.5.6.tar.gz 847480
diff --git a/dev-python/pygame/pygame-1.5.6.ebuild b/dev-python/pygame/pygame-1.5.6.ebuild
new file mode 100644
index 000000000000..d4354e1bd61c
--- /dev/null
+++ b/dev-python/pygame/pygame-1.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.5.6.ebuild,v 1.1 2003/06/11 07:00:43 vladimir Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.pygame.org/"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~sparc ~alpha"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/Numeric-22.0*
+ >=media-libs/smpeg-0.4.4-r1"
+
+inherit distutils
+
+src_install () {
+ mydoc=WHATSNEW
+ distutils_src_install
+
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+}
+