summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/XML-Parser/XML-Parser-2.36.ebuild')
-rw-r--r--dev-perl/XML-Parser/XML-Parser-2.36.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/XML-Parser/XML-Parser-2.36.ebuild b/dev-perl/XML-Parser/XML-Parser-2.36.ebuild
new file mode 100644
index 000000000000..cbe6722a8a01
--- /dev/null
+++ b/dev-perl/XML-Parser/XML-Parser-2.36.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Parser/XML-Parser-2.36.ebuild,v 1.1 2008/04/29 00:27:30 yuval Exp $
+
+inherit perl-module multilib
+
+DESCRIPTION="A Perl extension interface to James Clark's XML parser, expat"
+HOMEPAGE="http://search.cpan.org/~msergeant/"
+SRC_URI="mirror://cpan/authors/id/M/MS/MSERGEANT/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-libs/expat-1.95.1-r1
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^\$expat_libpath.*:\$expat_libpath = '/usr/$(get_libdir)';:" \
+ Makefile.PL || die "sed failed"
+}