summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild')
-rw-r--r--dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild b/dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild
new file mode 100644
index 000000000000..e6ba6c53326f
--- /dev/null
+++ b/dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-MakeMethods-Template/Class-MakeMethods-Template-1.004-r1.ebuild,v 1.1 2002/10/30 07:20:34 seemant Exp $
+
+inherit perl-module
+
+MY_P=Class-MakeMethods-Template-${PV}
+S=${WORKDIR}/${MY_P}
+CATEGORY="dev-perl"
+DESCRIPTION="Extensible temlpates for Class::MakeMethods"
+SRC_URI="http://www.cpan.org/modules/by-module/Class/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-module/Class/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+newdepend ">=Class-MakeMethods-1.003"
+
+src_compile() {
+ perl-module_src_compile
+ perl-module_src_test || die "test failed"
+}