summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild')
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
index 10f402a4bf0c..75916f6ee5c8 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild,v 1.5 2014/07/27 18:00:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild,v 1.6 2014/07/28 16:19:56 ssuominen Exp $
EAPI="4"
@@ -10,18 +10,21 @@ DESCRIPTION="UPower-based power manager for LeechCraft"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug"
+IUSE="debug systemd"
DEPEND="~app-leechcraft/lc-core-${PV}
x11-libs/qwt:6
dev-qt/qtdbus:4
virtual/leechcraft-trayarea"
RDEPEND="${DEPEND}
- || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )"
+ !systemd? ( || ( >=sys-power/upower-0.99 sys-power/upower-pm-utils ) )
+ systemd? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
pkg_postinst() {
if has_version '>=sys-power/upower-0.99'; then
- ewarn "If you need hibernate and suspend support, you need to downgrade"
- ewarn "sys-power/upower to 0.9.23 or switch to sys-power/upower-pm-utils"
+ ewarn "The new sys-power/upower version you have installed doesn't have hibernate"
+ ewarn "and suspend. If you need hibernate and suspend in ${PN}, and you use"
+ ewarn "systemd, you should downgrade sys-power/upower to 0.9.23 series. All others"
+ ewarn "should switch to sys-power/upower-pm-utils, also to 0.9.23 series."
fi
}