summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-6.ebuild27
-rwxr-xr-xsys-devel/autoconf-wrapper/files/ac-wrapper-6.sh162
-rw-r--r--sys-devel/autoconf/Manifest14
3 files changed, 13 insertions, 190 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-6.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-6.ebuild
deleted file mode 100644
index 8ce392f4bfc3..000000000000
--- a/sys-devel/autoconf-wrapper/autoconf-wrapper-6.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-6.ebuild,v 1.8 2009/01/15 16:02:22 vapier Exp $
-
-inherit multilib
-
-DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-S=${WORKDIR}
-
-src_install() {
- exeinto /usr/$(get_libdir)/misc
- newexe "${FILESDIR}"/ac-wrapper-${PV}.sh ac-wrapper.sh || die
-
- dodir /usr/bin
- local x=
- for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
- dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
- done
-}
diff --git a/sys-devel/autoconf-wrapper/files/ac-wrapper-6.sh b/sys-devel/autoconf-wrapper/files/ac-wrapper-6.sh
deleted file mode 100755
index cc0328bf33b6..000000000000
--- a/sys-devel/autoconf-wrapper/files/ac-wrapper-6.sh
+++ /dev/null
@@ -1,162 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/files/ac-wrapper-6.sh,v 1.1 2008/09/20 17:46:47 vapier Exp $
-
-# Based on the ac-wrapper.pl script provided by MandrakeSoft
-# Rewritten in bash by Gregorio Guidi
-#
-# Executes the correct autoconf version.
-#
-# - defaults to newest version available (hopefully autoconf-2.60)
-# - runs autoconf 2.13 if:
-# - envvar WANT_AUTOCONF is set to `2.1'
-# -or-
-# - `ac{local,include}.m4' or `configure.{in,ac}' have AC_PREREQ(2.1) (not higher)
-# -or-
-# - `configure' is already present and was generated by autoconf 2.13
-
-if [[ ${0##*/} == "ac-wrapper.sh" ]] ; then
- echo "Don't call this script directly" >&2
- exit 1
-fi
-
-if [[ ${WANT_AUTOCONF} == "2.1" && ${0##*/} == "autom4te" ]] ; then
- echo "ac-wrapper: Autoconf 2.13 doesn't contain autom4te." >&2
- echo " Either unset WANT_AUTOCONF or don't execute anything" >&2
- echo " that would use autom4te." >&2
- exit 1
-fi
-
-#
-# Set up bindings between actual version and WANT_AUTOCONF
-#
-vers="2.63:2.5 2.62:2.5 2.61:2.5 2.60:2.5 2.59:2.5 2.13:2.1"
-
-binary=""
-for v in ${vers} ; do
- auto_ver=${v%:*}
- if [ -z "${binary}" ] && [ -x "${0}-${auto_ver}" ] ; then
- binary="${0}-${auto_ver}"
- fi
-done
-if [ -z "${binary}" ] ; then
- echo "ac-wrapper: Unable to locate any usuable version of autoconf." >&2
- echo " I tried these versions: ${vers}" >&2
- echo " With a base name of '${0}'." >&2
- exit 1
-fi
-
-#
-# Check the WANT_AUTOCONF setting. We accept a whitespace delimited
-# list of autoconf versions.
-#
-if [ -n "${WANT_AUTOCONF}" ] ; then
- for v in ${vers} x ; do
- if [ "${v}" = "x" ] ; then
- echo "ac-wrapper: warning: invalid WANT_AUTOCONF '${WANT_AUTOCONF}'; ignoring." >&2
- unset WANT_AUTOCONF
- break
- fi
-
- auto_ver=${v%:*}
- want_ver=${v#*:}
- for wx in ${WANT_AUTOCONF} ; do
- if [ "${wx}" = "${want_ver}" ] && [ -x "${0}-${auto_ver}" ] ; then
- binary="${0}-${auto_ver}"
- v="x"
- fi
- done
- [ "${v}" = "x" ] && break
- done
-fi
-
-#
-# autodetect helpers
-#
-acprereq_version() {
- gawk \
- '($0 !~ /^[[:space:]]*(#|dnl)/) {
- if (match($0, "AC_PREREQ\\(\\[?([0-9]\\.[0-9])", res))
- VERSIONS[COUNT++] = res[1]
- }
-
- END {
- asort(VERSIONS)
- print VERSIONS[COUNT]
- }' "$@"
-}
-
-generated_version() {
- gawk \
- '{
- if (match($0,
- "^# Generated (by (GNU )?Autoconf|automatically using autoconf version) ([0-9].[0-9])",
- res)) {
- print res[3]
- exit
- }
- }' "$@"
-}
-
-#
-# autodetect routine
-#
-if [[ ${WANT_AUTOCONF} == "2.1" ]] && [ -f "configure.ac" ] ; then
- echo "ac-wrapper: Since configure.ac is present, aclocal always use" >&2
- echo " autoconf 2.59+, which conflicts with your choice and" >&2
- echo " causes error. You have two options:" >&2
- echo " 1. Try execute command again after removing configure.ac" >&2
- echo " 2. Don't set WANT_AUTOCONF" >&2
- exit 1
-fi
-
-if [[ ${WANT_AUTOCONF} != "2.5" ]] && [[ -n ${WANT_AUTOMAKE} ]] ; then
- # Automake-1.7 and better require autoconf-2.5x so if WANT_AUTOMAKE
- # is set to an older version, let's do some sanity checks.
- case "${WANT_AUTOMAKE}" in
- 1.[456])
- acfiles=$(ls ac{local,include}.m4 configure.{in,ac} 2>/dev/null)
- [[ -n ${acfiles} ]] && confversion=$(acprereq_version ${acfiles})
-
- [[ -z ${confversion} && -r "configure" ]] \
- && confversion=$(generated_version configure)
-
- if [[ ${confversion} == "2.1" && ! -f "configure.ac" ]] ; then
- binary="${0}-2.13"
- fi
- esac
-fi
-
-if [[ -n ${WANT_ACWRAPPER_DEBUG} ]] ; then
- if [[ -n ${WANT_AUTOCONF} ]] ; then
- echo "ac-wrapper: DEBUG: WANT_AUTOCONF is set to ${WANT_AUTOCONF}" >&2
- fi
- echo "ac-wrapper: DEBUG: will execute <${binary}>" >&2
-fi
-
-#
-# for further consistency
-#
-for v in ${vers} ; do
- auto_ver=${v%:*}
- want_ver=${v#*:}
- if [ "${binary}" = "${0}-${auto_ver}" ] ; then
- export WANT_AUTOCONF="${want_ver}"
- fi
-done
-
-#
-# Now try to run the binary
-#
-if [[ ! -x ${binary} ]] ; then
- # this shouldn't happen
- echo "ac-wrapper: ${binary} is missing or not executable." >&2
- echo " Please try emerging the correct version of autoconf." >&2
- exit 1
-fi
-
-exec "${binary}" "$@"
-
-echo "ac-wrapper: was unable to exec ${binary} !?" >&2
-exit 1
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index abc54436abd1..0719763d5750 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX autoconf-2.13-destdir.patch 677 RMD160 ff71fb18c1676455e267dfd8f3059e8c9384fe19 SHA1 5ef1905e271e078cecea3424560207585868e9cd SHA256 67c3eaf2f8aaf3acbcff387bc3fc6d46688b56a6b51043344e301bfaf16186a0
AUX autoconf-2.13-gentoo.patch 898 RMD160 c39068cd8477188cde4818049c32b4142689ca0d SHA1 17bdf4d77c8a0c738f20378f0b281fd6ecf57ddd SHA256 5d6a4b9d8d789684b44addf565200a90ee92140d58bebf087373ae82c4d89ea8
AUX autoconf-2.13-test-fixes.patch 547 RMD160 4f8713f9a046c496c813fc52f5fccbb8d616f97c SHA1 95dcffbc29c8355f11c191d6626b54f1db9403ea SHA256 43929d95e6050642385530df91084d4c073cec5cca727918d5ff84bc1e3059f5
@@ -14,6 +17,7 @@ DIST autoconf-2.61.tar.gz 1396855 RMD160 ec5f512aec24b3cc5a9968e96d261558e45471b
DIST autoconf-2.62.tar.gz 1518427 RMD160 316220038dd0fc131fd93e1fbfe422f7c67b4164 SHA1 74b2fcffb32b16d248103f42111284331d7bab75 SHA256 83aa747e6443def0ebd1882509c53f5a2133f502ddefa21b3de141c433914bdd
DIST autoconf-2.63.tar.gz 1562665 RMD160 4254fd31f9bcaf8932e2c10cf33f52b9f7f7eb19 SHA1 d42eebd3d342925116c3cb942e9320d5803fcb1a SHA256 b05a6cee81657dd2db86194a6232b895b8b2606a30a399c3a566d9259366744b
DIST autoconf-2.64.tar.bz2 1313833 RMD160 cf498949b3cc0a6bc465a50114c98750871bcf49 SHA1 dfbcdbd7dd74a52130dda324e9d94ee0b8551466 SHA256 872f4cadf12e7e7c8a2414e047fdff26b517c7f1a977d72433c124d0d3acaa85
+DIST autoconf-2.65.tar.bz2 1332522 RMD160 250b0f46ae6f81fe47f30ae61335a2291d736197 SHA1 9126ffb8d7d59f38f305ef53e208531d4b75bb87 SHA256 db11944057f3faf229ff5d6ce3fcd819f565455c152b72cec17ebc1cbb80136b
EBUILD autoconf-2.13.ebuild 1502 RMD160 63e5d35cbf9dc4ba0d8403cbc2cfb41fbdfd79cb SHA1 3577386ef857c4241df85935f4321d8f47865cb6 SHA256 7c9eef56913ee5d6b2314bf7ef6a80d17484fe99abcb6756050cb95861376618
EBUILD autoconf-2.59-r7.ebuild 1390 RMD160 4a121f59f18d690e5277ab2d36891f5380ddbcc3 SHA1 ae2b107ebeb6a81d321f99038f37c3b237a07711 SHA256 20eb61830e14aee28604b72395c2d0b455cbc12fe0d33e7d182848a58ffe6f4f
EBUILD autoconf-2.61-r2.ebuild 1311 RMD160 01448158ef2e988e23f31001346b0b99fe9e6636 SHA1 9cead036243914062e08a0e571367167626bcfb2 SHA256 2c9312cc62383dcf64334e61df139168efc997b2e2fccf7aa8316369e214b965
@@ -21,6 +25,14 @@ EBUILD autoconf-2.62-r1.ebuild 1447 RMD160 38c899c660b48e663b5fe6f4944c45396f039
EBUILD autoconf-2.63-r1.ebuild 1309 RMD160 9b8dc1c85f0e9997915b990bb252003095651e26 SHA1 f98ddada8815e07758c02e7c3bfc74cd8ab4909d SHA256 639f04392ee83f5b1c20831fa4e61aabd1b94282911c66665a23cacc59a3735d
EBUILD autoconf-2.63.ebuild 1204 RMD160 703b089cb25bc9a3880f834107f87e17c6330559 SHA1 6ba8954b1891b3b4cf0b27d43b68a12404987e63 SHA256 45cb1f6af8d7c63adf601cfa8ba2d9a5e736995ac6daccfc5a591f413e95cec6
EBUILD autoconf-2.64.ebuild 1266 RMD160 823a1055d7fbf7c4b628b748037dc147ca9a7fca SHA1 000f3198920e25ecc8a1eb9eb74a9b9039b9d4d0 SHA256 40846864f1ce72d9087643cf6964071713fe83a847b9f206b78cac806f9df2aa
+EBUILD autoconf-2.65.ebuild 1266 RMD160 58e0b61d76d15a260a2b966eaa5ae6f6e807eae7 SHA1 d2cf833082e39c9b4b7c9427eabd888c4167766b SHA256 cb5dc9759e1ae303d16c6dbf3c6778c850336247526467b9a9118b3216db31f6
EBUILD autoconf-9999.ebuild 1262 RMD160 46da23705fa4033b0a420507aaba52eeb3364af1 SHA1 b64c10c9fbd1cf34e2802474e021576e712d78c8 SHA256 0fc59822d4289bbd38a6f0a55374b7cc5c3ff61fafeb25301728e6cd11d68d31
-MISC ChangeLog 18889 RMD160 21efede3a49ba763b5f9e93e36e129abe4a6f537 SHA1 e7302098b46792dc781444bb912e32963c433d4c SHA256 306d4bfa0cf0eb2bd91bd2c810d7ccf3a3e53f9c1da5a4e3c138460464994739
+MISC ChangeLog 19009 RMD160 82b05a774e3df060a5af92ec95a60dd7b6fe9070 SHA1 25572d1d81189ab88b562e0b1327c0ad3367cb9b SHA256 b0760fa2576752996d4736dd27b190aec6214fd388e6144a6681782f4b5cae2e
MISC metadata.xml 164 RMD160 f43cbec30b7074319087c9acffdb9354b17b0db3 SHA1 9c213f5803676c56439df3716be07d6692588856 SHA256 f5f2891f2a4791cd31350bb2bb572131ad7235cd0eeb124c9912c187ac10ce92
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.13 (GNU/Linux)
+
+iEYEARECAAYFAksIPIkACgkQlPl3HsVfCDolDwCeJ9AvR+7Viq1nHfHt3e10ZO17
+fGQAnijaLc0cJ9SqYi0YNnXqVN+q7GbS
+=Qo98
+-----END PGP SIGNATURE-----