summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-18 08:18:52 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-18 08:18:52 +0000
commite369cae77703ddb08f2402cb27f3295e192afcd7 (patch)
tree4424d7c842237539bcc0f212af9ee6abe3604148 /x11-misc/entrance
parentforgot to update this guy too :) (diff)
downloadhistorical-e369cae77703ddb08f2402cb27f3295e192afcd7.tar.gz
historical-e369cae77703ddb08f2402cb27f3295e192afcd7.tar.bz2
historical-e369cae77703ddb08f2402cb27f3295e192afcd7.zip
fix compile #31226
Diffstat (limited to 'x11-misc/entrance')
-rw-r--r--x11-misc/entrance/ChangeLog7
-rw-r--r--x11-misc/entrance/entrance-0.9.0.20031018.ebuild41
-rw-r--r--x11-misc/entrance/files/0.9.0.20031018-gentoo-sessions.patch61
-rw-r--r--x11-misc/entrance/files/digest-entrance-0.9.0.200310182
4 files changed, 110 insertions, 1 deletions
diff --git a/x11-misc/entrance/ChangeLog b/x11-misc/entrance/ChangeLog
index 6990a9000320..d263e4749ea3 100644
--- a/x11-misc/entrance/ChangeLog
+++ b/x11-misc/entrance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/entrance
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/ChangeLog,v 1.6 2003/10/14 03:48:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/ChangeLog,v 1.7 2003/10/18 08:18:52 vapier Exp $
+
+*entrance-0.9.0.20031018 (18 Oct 2003)
+
+ 18 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Ver bump to fix #31226.
*entrance-0.9.0.20031013 (13 Oct 2003)
diff --git a/x11-misc/entrance/entrance-0.9.0.20031018.ebuild b/x11-misc/entrance/entrance-0.9.0.20031018.ebuild
new file mode 100644
index 000000000000..0fccb2e8ae42
--- /dev/null
+++ b/x11-misc/entrance/entrance-0.9.0.20031018.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20031018.ebuild,v 1.1 2003/10/18 08:18:52 vapier Exp $
+
+inherit enlightenment eutils
+
+DESCRIPTION="next generation of Elogin, a login/display manager for X"
+HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/extraicons-1.tar.bz2
+ http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+
+DEPEND="${DEPEND}
+ virtual/x11
+ sys-libs/pam
+ >=dev-db/edb-1.0.4.20031013
+ >=x11-libs/evas-1.0.0.20031013_pre11
+ >=x11-libs/ecore-0.0.2.20031013_pre4
+ >=media-libs/edje-0.0.1.20031013"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo-sessions.patch
+ gettext_modify
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/pam.d
+ doins config/pam.d/entrance
+ insinto /usr/share/entrance/images/sessions
+ doins ${WORKDIR}/extraicons/*
+ exeinto /usr/share/entrance
+ doexe data/config/build_config.sh
+}
+
+pkg_postinst() {
+ cd /usr/share/entrance
+ ./build_config.sh || die
+}
diff --git a/x11-misc/entrance/files/0.9.0.20031018-gentoo-sessions.patch b/x11-misc/entrance/files/0.9.0.20031018-gentoo-sessions.patch
new file mode 100644
index 000000000000..d1ee0b84b4bb
--- /dev/null
+++ b/x11-misc/entrance/files/0.9.0.20031018-gentoo-sessions.patch
@@ -0,0 +1,61 @@
+--- data/config/build_config.sh.orig 2003-10-08 11:30:08.000000000 -0400
++++ data/config/build_config.sh 2003-10-13 23:33:55.864502000 -0400
+@@ -1,4 +1,4 @@
+-#!/bin/sh -e
++#!/bin/bash
+ DB="./entrance_config.db"
+ rm -f $DB
+
+@@ -14,24 +14,33 @@
+ #edb_ed $DB add /entrance/fonts/count int 2
+ #edb_ed $DB add /entrance/fonts/0/str str "/usr/share/fonts/truetype/"
+ #edb_ed $DB add /entrance/fonts/1/str str "/usr/X11R6/lib/X11/fonts/Truetype/"
+-edb_ed $DB add /entrance/session/count int 9
+-edb_ed $DB add /entrance/session/0/value str ""
+-edb_ed $DB add /entrance/session/0/key str "Default"
+-edb_ed $DB add /entrance/session/1/value str "enlightenment"
+-edb_ed $DB add /entrance/session/1/key str "Enlightenment"
+-edb_ed $DB add /entrance/session/2/value str "kde"
+-edb_ed $DB add /entrance/session/2/key str "KDE"
+-edb_ed $DB add /entrance/session/3/value str "gnome"
+-edb_ed $DB add /entrance/session/3/key str "Gnome"
+-edb_ed $DB add /entrance/session/4/value str "gnome"
+-edb_ed $DB add /entrance/session/4/key str "Gnome"
+-edb_ed $DB add /entrance/session/5/value str "blackbox"
+-edb_ed $DB add /entrance/session/5/key str "Blackbox"
+-edb_ed $DB add /entrance/session/6/value str "sawfish"
+-edb_ed $DB add /entrance/session/6/key str "Sawfish"
+-edb_ed $DB add /entrance/session/7/value str "xfce"
+-edb_ed $DB add /entrance/session/7/key str "XFce"
+-edb_ed $DB add /entrance/session/8/value str "failsafe"
+-edb_ed $DB add /entrance/session/8/key str "Failsafe"
++
++pick_icon() {
++ case "`basename $(echo $1 | awk '{print toupper($1)}')`" in
++ KDE*) echo -n "kde";;
++ GNOME*) echo -n "gnome";;
++ ENLIGHTENMENT) echo -n "e16";;
++ E17) echo -n "enlightenment";;
++ WMAKER) echo -n "widowmaker";;
++ BLACKBOX) echo -n "blackbox";;
++ *) echo -n "default";;
++ esac
++ echo ".png";
++}
++
++count=-1
++for ses in /etc/X11/Sessions/* ; do
++ let "count++"
++ edb_ed $DB add /entrance/session/${count}/name str "`basename ${ses}`"
++ edb_ed $DB add /entrance/session/${count}/path str "${ses}"
++ edb_ed $DB add /entrance/session/${count}/icon str "`pick_icon ${ses}`"
++done
++let "count++"
++edb_ed $DB add /entrance/session/${count}/name str "Failsafe"
++edb_ed $DB add /entrance/session/${count}/path str "/etc/X11/Sessions/Xsession failsafe"
++edb_ed $DB add /entrance/session/${count}/icon str "default.png"
++edb_ed $DB add /entrance/session/count int ${count}
++edb_ed $DB add /entrance/session/default int 0
++
+ edb_ed $DB add /entrance/system/reboot int 1
+ edb_ed $DB add /entrance/system/halt int 1
diff --git a/x11-misc/entrance/files/digest-entrance-0.9.0.20031018 b/x11-misc/entrance/files/digest-entrance-0.9.0.20031018
new file mode 100644
index 000000000000..a9fc6927ce0d
--- /dev/null
+++ b/x11-misc/entrance/files/digest-entrance-0.9.0.20031018
@@ -0,0 +1,2 @@
+MD5 351d9ed9cc46f340a468b1dd81b4f1eb entrance-0.9.0.20031018.tar.bz2 8517545
+MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770