summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-06-17 01:16:07 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-06-17 01:16:07 +0000
commit1aef21e5cc749bbe77085b3fb4548ec694d4ff2f (patch)
tree882fd87544264b9223e934f412651e922cb37a51 /www-client
parentDo not include gtypes.h, bug #421415 (diff)
downloadhistorical-1aef21e5cc749bbe77085b3fb4548ec694d4ff2f.tar.gz
historical-1aef21e5cc749bbe77085b3fb4548ec694d4ff2f.tar.bz2
historical-1aef21e5cc749bbe77085b3fb4548ec694d4ff2f.zip
Version bump.
Package-Manager: portage-2.2.0_alpha110/cvs/Linux i686
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox-bin/ChangeLog7
-rw-r--r--www-client/firefox-bin/firefox-bin-13.0.1.ebuild138
-rw-r--r--www-client/seamonkey-bin/ChangeLog7
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.10.1.ebuild105
4 files changed, 255 insertions, 2 deletions
diff --git a/www-client/firefox-bin/ChangeLog b/www-client/firefox-bin/ChangeLog
index 93dd4b9a3135..9edf8c4c7c8d 100644
--- a/www-client/firefox-bin/ChangeLog
+++ b/www-client/firefox-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/firefox-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.105 2012/06/11 12:23:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.106 2012/06/17 01:16:07 jdhore Exp $
+
+*firefox-bin-13.0.1 (17 Jun 2012)
+
+ 17 Jun 2012; Jeff Horelick <jdhore@gentoo.org> +firefox-bin-13.0.1.ebuild:
+ Version bump.
11 Jun 2012; Agostino Sarubbo <ago@gentoo.org> firefox-bin-10.0.5.ebuild:
Stable for amd64, wrt bug #420125
diff --git a/www-client/firefox-bin/firefox-bin-13.0.1.ebuild b/www-client/firefox-bin/firefox-bin-13.0.1.ebuild
new file mode 100644
index 000000000000..8d12c31aa83f
--- /dev/null
+++ b/www-client/firefox-bin/firefox-bin-13.0.1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-13.0.1.ebuild,v 1.1 2012/06/17 01:16:07 jdhore Exp $
+
+EAPI="4"
+
+# Can be updated using scripts/get_langs.sh from mozilla overlay
+MOZ_LANGS=(af ak ar as ast be bg bn-BD bn-IN br bs ca cs csb cy da de el en
+en-GB en-US en-ZA eo es-AR es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gd gl
+gu-IN he hi-IN hr hu hy-AM id is it ja kk kn ko ku lg lt lv mai mk ml mr nb-NO
+nl nn-NO nso or pa-IN pl pt-BR pt-PT rm ro ru si sk sl son sq sr sv-SE ta ta-LK
+te th tr uk vi zh-CN zh-TW zu)
+
+# Convert the ebuild version to the upstream mozilla version, used by mozlinguas
+MOZ_PV="${PV/_beta/b}" # Handle beta for SRC_URI
+MOZ_PV="${MOZ_PV/_rc/rc}" # Handle rc for SRC_URI
+MOZ_PN="${PN/-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
+# Upstream ftp release URI that's used by mozlinguas.eclass
+# We don't use the http mirror because it deletes old tarballs.
+MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MOZ_PN}/releases/"
+
+inherit eutils multilib pax-utils fdo-mime gnome2-utils mozlinguas nsplugins
+
+DESCRIPTION="Firefox Web Browser"
+MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MOZ_PN}/releases"
+SRC_URI="${SRC_URI}
+ amd64? ( ${MOZ_FTP_URI}/${MOZ_PV}/linux-x86_64/en-US/${MOZ_P}.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${MOZ_FTP_URI}/${MOZ_PV}/linux-i686/en-US/${MOZ_P}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
+HOMEPAGE="http://www.mozilla.com/firefox"
+RESTRICT="strip mirror binchecks"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="startup-notification"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ virtual/freedesktop-icon-theme
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+
+ >=x11-libs/gtk+-2.2:2
+ >=media-libs/alsa-lib-1.0.16
+"
+
+S="${WORKDIR}/${MOZ_PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Unpack language packs
+ mozlinguas_src_unpack
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/${MOZ_PN}
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ # Add StartupNotify=true bug 237317
+ if use startup-notification; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}.desktop
+ fi
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME} || die
+
+ # Fix prefs that make no sense for a system-wide install
+ insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
+ doins "${FILESDIR}"/${PN}-prefs.js || die
+
+ # Install language packs
+ mozlinguas_src_install
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ echo "pref(\"general.useragent.locale\", \"${LANG}\");" \
+ >> "${D}${MOZILLA_FIVE_HOME}"/defaults/pref/${PN}-prefs.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox-bin
+ dodir /usr/bin/
+ cat <<-EOF >"${D}"/usr/bin/${PN}
+ #!/bin/sh
+ unset LD_PRELOAD
+ LD_LIBRARY_PATH="/opt/firefox/"
+ GTK_PATH=/usr/lib/gtk-2.0/
+ exec /opt/${MOZ_PN}/${MOZ_PN} "\$@"
+ EOF
+ fperms 0755 /usr/bin/${PN}
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10${PN} || die
+
+ # Plugins dir
+ share_plugins_dir
+
+ # Required in order to use plugins and even run firefox on hardened.
+ pax-mark mr "${ED}"/${MOZILLA_FIVE_HOME}/{firefox,firefox-bin,plugin-container}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl[nss]'; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 4cedcf47fd00..5dfb90f0be9b 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.138 2012/06/11 12:29:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.139 2012/06/17 01:14:28 jdhore Exp $
+
+*seamonkey-bin-2.10.1 (17 Jun 2012)
+
+ 17 Jun 2012; Jeff Horelick <jdhore@gentoo.org> +seamonkey-bin-2.10.1.ebuild:
+ Version bump.
11 Jun 2012; Agostino Sarubbo <ago@gentoo.org> seamonkey-bin-2.10.ebuild:
Stable for amd64, wrt bug #419917
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.10.1.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.10.1.ebuild
new file mode 100644
index 000000000000..c42db48c79d5
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.10.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.10.1.ebuild,v 1.1 2012/06/17 01:14:28 jdhore Exp $
+
+EAPI="4"
+
+# This list can be updated with scripts/get_langs.sh from the mozilla overlay
+MOZ_LANGS=(be ca cs de en-GB en-US es-AR es-ES fi fr gl hu it ja lt nb-NO nl pl
+pt-PT ru sk sv-SE tr uk zh-CN zh-TW)
+
+MOZ_PV="${PV/_alpha/a}" # Handle alpha for SRC_URI
+MOZ_PV="${MOZ_PV/_beta/b}" # Handle beta for SRC_URI
+MOZ_PV="${MOZ_PV/_rc/rc}" # Handle rc for SRC_URI
+MOZ_PN="${PN/-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
+MOZ_LANGPACK_PREFIX="${MOZ_PV}/langpack/${MOZ_P}."
+MOZ_LANGPACK_SUFFIX=".langpack.xpi"
+
+MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MOZ_PN}/releases/"
+
+inherit eutils multilib mozextension pax-utils nsplugins fdo-mime gnome2-utils mozlinguas
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="${SRC_URI}
+ amd64? ( ${MOZ_FTP_URI}/${MOZ_PV}/contrib/${MOZ_P}.en-US.linux-x86_64.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${MOZ_FTP_URI}/${MOZ_PV}/linux-i686/en-US/${MOZ_P}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip mirror binchecks"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="startup-notification"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ >=media-libs/alsa-lib-1.0.16
+ virtual/freedesktop-icon-theme
+ >=x11-libs/gtk+-2.10:2
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${MOZ_PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Unpack language packs
+ mozlinguas_src_unpack
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Install language packs
+ mozlinguas_src_install
+
+ # Create /usr/bin/seamonkey-bin
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/seamonkey-bin
+#!/bin/sh
+unset LD_PRELOAD
+exec /opt/seamonkey/seamonkey "\$@"
+EOF
+ fperms 0755 /usr/bin/seamonkey-bin
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+
+ if use startup-notification; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}.desktop
+ fi
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10${PN} || die
+
+ # Handle plugins dir through nsplugins.eclass
+ share_plugins_dir
+
+ # Required in order to use plugins and even run seamonkey on hardened.
+ pax-mark mr "${ED}"/${MOZILLA_FIVE_HOME}/{seamonkey,seamonkey-bin,plugin-container}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}