summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2003-06-26 00:41:33 +0000
committerBryon Roche <kain@gentoo.org>2003-06-26 00:41:33 +0000
commit4d6c55d9c719a33b6b7c49de2791ca06d8f2dfa5 (patch)
tree9e4e3cba28d499087bcb036bdebd1b80c531ff4f /sys-kernel/ppc-sources
parentnew benh updates (diff)
downloadhistorical-4d6c55d9c719a33b6b7c49de2791ca06d8f2dfa5.tar.gz
historical-4d6c55d9c719a33b6b7c49de2791ca06d8f2dfa5.tar.bz2
historical-4d6c55d9c719a33b6b7c49de2791ca06d8f2dfa5.zip
new benh updates
Diffstat (limited to 'sys-kernel/ppc-sources')
-rw-r--r--sys-kernel/ppc-sources/Manifest4
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.21-r22
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.21-r2.ebuild63
3 files changed, 67 insertions, 2 deletions
diff --git a/sys-kernel/ppc-sources/Manifest b/sys-kernel/ppc-sources/Manifest
index 4a175c442095..71d6dc84e3c0 100644
--- a/sys-kernel/ppc-sources/Manifest
+++ b/sys-kernel/ppc-sources/Manifest
@@ -1,5 +1,5 @@
-MD5 c7d29967b22fbf612e31ea58d263a24c ChangeLog 3998
-MD5 e852d5a2f7f1b9c9b9023c86eefb2935 ppc-sources-2.4.21-r2.ebuild 2040
+MD5 869910ff0e263db50eea794283e77719 ChangeLog 3994
+MD5 8cf907d7a6c80ea5352a8ae1b8c5913f ppc-sources-2.4.21-r2.ebuild 2040
MD5 a315035fd8ca715e0c03478ca1a8aabf ppc-sources-2.4.19-r3.ebuild 3296
MD5 7591f700f0b3d51d43c22f9436fb7313 ppc-sources-2.4.19-r4.ebuild 3453
MD5 fdc0a65d9391b95aabd0d4377dec3e3b ppc-sources-2.4.19-r5.ebuild 3295
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.21-r2 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.21-r2
new file mode 100644
index 000000000000..e2f56b7986b3
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.21-r2
@@ -0,0 +1,2 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 59f4728dc011ba37339bed6eb8dc1c3c patches-2.4.21-ppc-r2.tar.bz2 347815
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.21-r2.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.21-r2.ebuild
new file mode 100644
index 000000000000..31bc8b9ad6de
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.21-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.21-r2.ebuild,v 1.1 2003/06/26 00:41:28 kain Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.21"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Kernel."
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+LICENSE="GPL-2"
+KEYWORDS="-x86 ~ppc -sparc -alpha -hppa -mips -arm"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+
+ cd ${WORKDIR}/${KV}
+
+ # This is the crypt USE flag, keeps {USAGI/superfreeswan/patch-int/loop-jari}
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8* ;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic patches will be applied"
+ fi
+
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ ewarn "There is no xfs support in this kernel."
+ echo
+ ewarn "If iptables/netfilter behaves abnormally, such as 'Invalid Argument',"
+ ewarn "you will need to re-emerge iptables to restore proper functionality."
+}