summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:19:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:19:54 +0000
commit70fdc6c29cd4e037bbf4ff6d78239ee9ccfcc32b (patch)
tree72e51e3f021cc440343625660b7dd7379876a7d6 /sci-astronomy/gasgano
parent[app-shells/zsh-completion] Works on ~amd64-fbsd (diff)
downloadhistorical-70fdc6c29cd4e037bbf4ff6d78239ee9ccfcc32b.tar.gz
historical-70fdc6c29cd4e037bbf4ff6d78239ee9ccfcc32b.tar.bz2
historical-70fdc6c29cd4e037bbf4ff6d78239ee9ccfcc32b.zip
Version bump
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'sci-astronomy/gasgano')
-rw-r--r--sci-astronomy/gasgano/ChangeLog7
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sci-astronomy/gasgano/ChangeLog b/sci-astronomy/gasgano/ChangeLog
index bcff0b2c57bf..e28a95ac602c 100644
--- a/sci-astronomy/gasgano/ChangeLog
+++ b/sci-astronomy/gasgano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/gasgano
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.5 2012/05/21 20:02:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.6 2012/06/04 22:15:20 bicatali Exp $
+
+*gasgano-2.4.3 (04 Jun 2012)
+
+ 04 Jun 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> +gasgano-2.4.3.ebuild:
+ Version bump
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> gasgano-2.4.0.ebuild:
inherit eutils for make_desktop_entry
diff --git a/sci-astronomy/gasgano/gasgano-2.4.3.ebuild b/sci-astronomy/gasgano/gasgano-2.4.3.ebuild
new file mode 100644
index 000000000000..3e40557c8582
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/gasgano-2.4.3.ebuild,v 1.1 2012/06/04 22:15:20 bicatali Exp $
+
+EAPI=4
+inherit eutils java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:BASE.*=.*:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e "s:/share/:/lib/:g" \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ newins "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+ fi
+}