summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 18:17:04 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 18:17:04 +0000
commit9bceb0123aed8188c3893a53243d10dc37c7d956 (patch)
tree49e4dcc3049c81934de84e620ffbf13dcbb18058 /net-analyzer
parentFix use invocation and don't run epatch in a subshell because then it can't die (diff)
downloadhistorical-9bceb0123aed8188c3893a53243d10dc37c7d956.tar.gz
historical-9bceb0123aed8188c3893a53243d10dc37c7d956.tar.bz2
historical-9bceb0123aed8188c3893a53243d10dc37c7d956.zip
Fix use invocation
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/ChangeLog7
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild18
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild14
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild10
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild10
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2.ebuild10
-rw-r--r--net-analyzer/net-snmp/ChangeLog6
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild2
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild8
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.1.1.ebuild2
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.1.ebuild8
-rw-r--r--net-analyzer/ntop/ChangeLog6
-rw-r--r--net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild4
-rw-r--r--net-analyzer/ntop/ntop-2.2.ebuild2
-rw-r--r--net-analyzer/ntop/ntop-2.2c.ebuild2
-rw-r--r--net-analyzer/ntop/ntop-3.0.ebuild2
16 files changed, 62 insertions, 49 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index fb13cbf6c009..24245a13cf35 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.25 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.26 2004/06/09 18:11:06 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> nagios-core-1.1-r4.ebuild,
+ nagios-core-1.1-r5.ebuild, nagios-core-1.1-r6.ebuild,
+ nagios-core-1.2-r1.ebuild, nagios-core-1.2.ebuild:
+ Fix use invocation
30 May 2004; Robin H. Johnson <robbat2@gentoo.org>
nagios-core-1.1-r4.ebuild, nagios-core-1.1-r5.ebuild,
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
index 92938d38c8a1..cb48dd222d58 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.12 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.13 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -37,7 +37,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/Makefile-distclean.diff.bz2
- [ `use gd` ] && epatch ${FILESDIR}/tac.cgi.diff.bz2
+ use gd && epatch ${FILESDIR}/tac.cgi.diff.bz2
}
src_compile() {
@@ -53,7 +53,7 @@ src_compile() {
use perl && myconf="${myconf} --enable-embedded-perl --with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -75,9 +75,9 @@ src_compile() {
src_install() {
dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
- if [ -n "`use gd`" ]; then
+ if use gd; then
make DESTDIR=${D} fullinstall install-config || die
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
else
@@ -122,12 +122,12 @@ pkg_postinst() {
einfo "Also, if you want nagios to start at boot time"
einfo "remember to execute rc-update add nagios default"
einfo
- if [ -n "`use gd`" ]; then
+ if use gd; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
einfo "to cgi directory for compiling"
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
einfo "To have nagios visable on the web, please do the following:"
einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
einfo "The Apache2 config file for nagios will be in"
@@ -154,8 +154,8 @@ pkg_postinst() {
}
pkg_config() {
- if [ "`use gd`" ]; then
- if [ "`use apache2`" ]; then
+ if use gd; then
+ if use apache2; then
einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
fi
echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
index 53912dd9cb79..68e44f0668f3 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.5 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.6 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -45,7 +45,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -82,7 +82,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -158,7 +158,7 @@ pkg_postinst() {
einfo "remember to execute rc-update add nagios default"
einfo
- if [ -z "`use noweb`"]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -167,7 +167,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -z "`use apache2`" ]; then
+ if ! use apache2; then
einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
else
einfo " 2. Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
@@ -191,8 +191,8 @@ pkg_postinst() {
}
pkg_config() {
- if [ -z "`use noweb`" ]; then
- if [ -n "`use apache2`" ]; then
+ if ! use noweb; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
index 117003a61e00..77a9ef116aee 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.6 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.7 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -44,7 +44,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -81,7 +81,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -163,7 +163,7 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -172,7 +172,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
index aa0f0c7f2e4d..7ed80179fd09 100644
--- a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.2 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.3 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -43,7 +43,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -80,7 +80,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -162,13 +162,13 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
einfo "to cgi directory for compiling."
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.2.ebuild b/net-analyzer/nagios-core/nagios-core-1.2.ebuild
index 163c27b474bd..ce3d3796c4ee 100644
--- a/net-analyzer/nagios-core/nagios-core-1.2.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2.ebuild,v 1.4 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2.ebuild,v 1.5 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -43,7 +43,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -80,7 +80,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -162,7 +162,7 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -171,7 +171,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index 202062795063..100eb881204b 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.43 2004/05/12 02:28:48 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.44 2004/06/09 18:15:11 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> net-snmp-5.0.9-r1.ebuild,
+ net-snmp-5.0.9-r3.ebuild, net-snmp-5.1.1.ebuild, net-snmp-5.1.ebuild:
+ Fix use invocation
11 May 2004; Michael McCabe <randy@gentoo.org> net-snmp-5.1.1.ebuild:
Added s390 keywords
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild
index 5f0fd97786c7..7e3d751599a6 100644
--- a/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild,v 1.10 2004/04/26 04:28:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.9-r1.ebuild,v 1.11 2004/06/09 18:15:11 agriffis Exp $
DESCRIPTION="Software for generating and retrieving SNMP data."
HOMEPAGE="http://net-snmp.sourceforge.net/"
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild
index 8970dd895793..888b8842d0aa 100644
--- a/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild,v 1.5 2004/04/26 04:28:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.9-r3.ebuild,v 1.6 2004/06/09 18:15:11 agriffis Exp $
inherit eutils fixheadtails
@@ -56,7 +56,7 @@ src_compile() {
emake -j1 || die "compile problem"
- if [ "`use perl`" ] ; then
+ if use perl ; then
emake perlmodules || die "compile perl modules problem"
fi
}
@@ -64,9 +64,9 @@ src_compile() {
src_install () {
einstall exec_prefix="${D}/usr" persistentdir="${D}/var/lib/net-snmp"
- if [ "`use perl`" ] ; then
+ if use perl ; then
make DESTDIR="${D}" perlinstall || die "make perlinstall failed"
- if [ ! "`use X`" ] ; then
+ if ! use X ; then
rm -f "${D}/usr/bin/tkmib"
fi
else
diff --git a/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild b/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild
index f4c5b8053e75..e0d2b5883149 100644
--- a/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild,v 1.4 2004/06/03 13:33:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.1.1.ebuild,v 1.5 2004/06/09 18:15:11 agriffis Exp $
inherit eutils
diff --git a/net-analyzer/net-snmp/net-snmp-5.1.ebuild b/net-analyzer/net-snmp/net-snmp-5.1.ebuild
index d326cd9c8754..2a651aec0410 100644
--- a/net-analyzer/net-snmp/net-snmp-5.1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.1.ebuild,v 1.6 2004/04/26 04:28:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.1.ebuild,v 1.7 2004/06/09 18:15:11 agriffis Exp $
inherit eutils
@@ -50,7 +50,7 @@ src_compile() {
emake -j1 || die "compile problem"
- if [ "`use perl`" ] ; then
+ if use perl ; then
emake perlmodules || die "compile perl modules problem"
fi
}
@@ -58,9 +58,9 @@ src_compile() {
src_install () {
einstall exec_prefix="${D}/usr" persistentdir="${D}/var/lib/net-snmp"
- if [ "`use perl`" ] ; then
+ if use perl ; then
make DESTDIR="${D}" perlinstall || die "make perlinstall failed"
- if [ ! "`use X`" ] ; then
+ if ! use X ; then
rm -f "${D}/usr/bin/tkmib"
fi
else
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 4e3f1a2da629..a018c77823ed 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ntop
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.22 2004/04/27 21:13:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.23 2004/06/09 18:17:04 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> ntop-2.0.99_rc2-r2.ebuild,
+ ntop-2.2.ebuild, ntop-2.2c.ebuild, ntop-3.0.ebuild:
+ Fix use invocation
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> ntop-2.2c.ebuild:
Add inherit eutils
diff --git a/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild b/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild
index fffe025185aa..bd2001b87ee3 100644
--- a/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild
+++ b/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild,v 1.10 2004/01/12 06:04:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2-r2.ebuild,v 1.11 2004/06/09 18:17:04 agriffis Exp $
IUSE="ssl readline mysql"
@@ -27,7 +27,7 @@ DEPEND=">=sys-libs/gdbm-1.8.0
src_compile() {
local myconf
- if [ -z "`use ssl`" ] ; then
+ if ! use ssl ; then
myconf="--disable-ssl"
else
sed -i "s:/usr/local/ssl:/usr:" configure
diff --git a/net-analyzer/ntop/ntop-2.2.ebuild b/net-analyzer/ntop/ntop-2.2.ebuild
index 3e23fa5b588d..d6ca8be5c5b1 100644
--- a/net-analyzer/ntop/ntop-2.2.ebuild
+++ b/net-analyzer/ntop/ntop-2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2.ebuild,v 1.5 2004/01/12 02:37:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2.ebuild,v 1.6 2004/06/09 18:17:04 agriffis Exp $
IUSE="ssl readline tcpd ncurses"
diff --git a/net-analyzer/ntop/ntop-2.2c.ebuild b/net-analyzer/ntop/ntop-2.2c.ebuild
index 5fecd6332a34..d298aa1622cc 100644
--- a/net-analyzer/ntop/ntop-2.2c.ebuild
+++ b/net-analyzer/ntop/ntop-2.2c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2c.ebuild,v 1.7 2004/04/27 21:13:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2c.ebuild,v 1.8 2004/06/09 18:17:04 agriffis Exp $
inherit eutils
diff --git a/net-analyzer/ntop/ntop-3.0.ebuild b/net-analyzer/ntop/ntop-3.0.ebuild
index f08a65e47079..0fb37ce905b3 100644
--- a/net-analyzer/ntop/ntop-3.0.ebuild
+++ b/net-analyzer/ntop/ntop-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.3 2004/04/14 17:39:12 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.4 2004/06/09 18:17:04 agriffis Exp $
IUSE="ssl readline tcpd ncurses"