summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2002-11-02 05:55:41 +0000
committerDean Bailey <alron@gentoo.org>2002-11-02 05:55:41 +0000
commit5f308f6142ec8004bfea946bfa0edbe3d29f1237 (patch)
treef3c13400dafc7d978caab9dae30a9c78e14db080 /net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild
parentnew package - calcoo: a good scientific calculator, supports RPN (diff)
downloadhistorical-5f308f6142ec8004bfea946bfa0edbe3d29f1237.tar.gz
historical-5f308f6142ec8004bfea946bfa0edbe3d29f1237.tar.bz2
historical-5f308f6142ec8004bfea946bfa0edbe3d29f1237.zip
Nagios in full.
Diffstat (limited to 'net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild')
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild
new file mode 100644
index 000000000000..2fddfa8a6d5b
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3_beta1.ebuild,v 1.1 2002/11/02 05:55:41 alron Exp $
+DESCRIPTION="Nagios #PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nagiosplug/nagiosplug-1.3-beta1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=bind-tools-9.2.2_rc1
+ >=openssl-0.9.6g
+ >=perl-5.6.1-r7
+ >=fping-2.4_beta2-r1
+ >=ntp-4.1.1a
+ >=Net-SNMP-4.0.1-r1
+ >=net-snmp-5.0.6
+ >=samba-2.2.5-r1
+ >=openssh-3.5_p1
+ >=mysql-3.23.52-r1
+ >=autoconf-2.53a"
+S="${WORKDIR}/nagiosplug-1.3-beta1"
+src_compile() {
+ patch -p1 < ${FILESDIR}/install-opts-fix.diff
+ autoconf
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --with-nagios-user=nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
+ make DESTDIR=${D} install || die
+}
+pkg_preinst() {
+ userdel nagios 2> /dev/null
+ if ! groupmod nagios; then
+ groupadd -g 75 nagios 2> /dev/null || \
+ die "Failed to create nagios group"
+ fi
+ useradd -u 75 -g nagios -s /dev/null -d /var/empty -c "nagios" nagios || \
+ die "Failed to create nagios user"
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
+}