summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2004-11-06 00:16:23 +0000
committerOlivier Crête <tester@gentoo.org>2004-11-06 00:16:23 +0000
commit69a4a674b0db0b992a54f97900fa8e9d20b489d1 (patch)
treeaf291f9b110cdaebd10a7e639e21512034bdecfc /media-video/mpeg4ip
parentVersion bump and clean up #70150 by Ervin Németh. (diff)
downloadhistorical-69a4a674b0db0b992a54f97900fa8e9d20b489d1.tar.gz
historical-69a4a674b0db0b992a54f97900fa8e9d20b489d1.tar.bz2
historical-69a4a674b0db0b992a54f97900fa8e9d20b489d1.zip
Fix compilation problems
Diffstat (limited to 'media-video/mpeg4ip')
-rw-r--r--media-video/mpeg4ip/ChangeLog6
-rw-r--r--media-video/mpeg4ip/Manifest18
-rw-r--r--media-video/mpeg4ip/files/mpeg4ip-1.1-gcc3.4.patch197
-rw-r--r--media-video/mpeg4ip/files/mpeg4ip-1.1-gentoo-fixes.patch22
-rw-r--r--media-video/mpeg4ip/mpeg4ip-1.1.ebuild10
5 files changed, 247 insertions, 6 deletions
diff --git a/media-video/mpeg4ip/ChangeLog b/media-video/mpeg4ip/ChangeLog
index 32cc7823a173..56ec4ebb354b 100644
--- a/media-video/mpeg4ip/ChangeLog
+++ b/media-video/mpeg4ip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mpeg4ip
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/ChangeLog,v 1.13 2004/07/26 04:04:52 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/ChangeLog,v 1.14 2004/11/06 00:16:23 tester Exp $
+
+ 05 Nov 2004; Olivier Crete <tester@gentoo.org> mpeg4ip-1.1.ebuild:
+ Fix compilation problems (bugs 60616, 65190). Thanks to
+ Tyler Montbriand <tsm@accesscomm.ca> and centic@gentoo.org.
26 Jul 2004; Travis Tilley <lv@gentoo.org> mpeg4ip-1.1.ebuild:
removed invalid blocker that prevents faad2 from being installed when mpeg4ip
diff --git a/media-video/mpeg4ip/Manifest b/media-video/mpeg4ip/Manifest
index fcbbe5521257..2c7a9b836dee 100644
--- a/media-video/mpeg4ip/Manifest
+++ b/media-video/mpeg4ip/Manifest
@@ -1,6 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d3901fe672ba3d47273a123d16228c72 mpeg4ip-1.0.ebuild 2205
-MD5 2773c4cf5f3bce4ccc59940dacc01247 ChangeLog 2430
+MD5 c8a2100f0de93083b91a846113e71916 ChangeLog 2625
MD5 1b1b7046bccf0f835f8e3c5b68063d8e metadata.xml 255
-MD5 2c2aa2b52a6956cc97cf77c7befcac58 mpeg4ip-1.1.ebuild 1498
-MD5 a00452dc115e6e8ddb761e17ccfb0a5a files/digest-mpeg4ip-1.0 64
+MD5 38fec26c4f5a37b44fc7d6862093b1cf mpeg4ip-1.1.ebuild 1624
MD5 bf208b3fef7857814d19fd17e38cbd66 files/digest-mpeg4ip-1.1 64
+MD5 47b75e71dec24165d7bcf3a5b55d785d files/mpeg4ip-1.1-gentoo-fixes.patch 844
+MD5 a00452dc115e6e8ddb761e17ccfb0a5a files/digest-mpeg4ip-1.0 64
+MD5 e4ff7ab91be9fcfe456f8c9d9d5050ce files/mpeg4ip-1.1-gcc3.4.patch 8110
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBjBfywDHaUUJ0mYMRAnpIAJ9VgmvMcl6p5aExnWXRPDTpH2f8TwCfTp4I
+udf3lTBD/O2MzEuC6bDIF1Q=
+=b+kx
+-----END PGP SIGNATURE-----
diff --git a/media-video/mpeg4ip/files/mpeg4ip-1.1-gcc3.4.patch b/media-video/mpeg4ip/files/mpeg4ip-1.1-gcc3.4.patch
new file mode 100644
index 000000000000..1c45dc4f1ca0
--- /dev/null
+++ b/media-video/mpeg4ip/files/mpeg4ip-1.1-gcc3.4.patch
@@ -0,0 +1,197 @@
+diff -ur mpeg4ip-1.1/common/video/mpeg4-2000/idct/idct.hpp mpeg4ip.new/common/video/mpeg4-2000/idct/idct.hpp
+--- mpeg4ip-1.1/common/video/mpeg4-2000/idct/idct.hpp 2003-10-23 01:26:59.000000000 +0200
++++ mpeg4ip.new/common/video/mpeg4-2000/idct/idct.hpp 2004-10-02 12:57:22.000000000 +0200
+@@ -54,7 +54,7 @@
+ void readin(const src *psrc, int stride){
+ short *p=block;
+ for(int row=0; row<IDCT_BLOCK_SIZE; row++, psrc+=stride, p+=IDCT_BLOCK_SIZE)
+- for(int col=0; col<BLOCK_SIZE; col++)
++ for(int col=0; col<IDCT_BLOCK_SIZE; col++)
+ p[col]=psrc[col];
+ }
+
+@@ -62,7 +62,7 @@
+ void writeout(dest *pdst, int stride){
+ short *p=block;
+ for(int row=0; row<IDCT_BLOCK_SIZE; row++, pdst+=stride, p+=IDCT_BLOCK_SIZE)
+- for(int col=0; col<BLOCK_SIZE; col++)
++ for(int col=0; col<IDCT_BLOCK_SIZE; col++)
+ pdst[col]=p[col];
+ }
+
+@@ -70,7 +70,7 @@
+ void clipWriteout(dest *pdst, int stride){
+ short *p=block;
+ for(int row=0; row<IDCT_BLOCK_SIZE; row++, pdst+=stride, p+=IDCT_BLOCK_SIZE)
+- for(int col=0; col<BLOCK_SIZE; col++)
++ for(int col=0; col<IDCT_BLOCK_SIZE; col++)
+ pdst[col]=clipping[p[col]];
+ };
+
+diff -ur mpeg4ip-1.1/server/mp4live/audio_encoder.h mpeg4ip.new/server/mp4live/audio_encoder.h
+--- mpeg4ip-1.1/server/mp4live/audio_encoder.h 2003-03-21 02:09:01.000000000 +0100
++++ mpeg4ip.new/server/mp4live/audio_encoder.h 2004-10-02 13:10:33.000000000 +0200
+@@ -31,17 +31,17 @@
+ public:
+ CAudioEncoder() { };
+
+- virtual u_int32_t GetSamplesPerFrame() = NULL;
++ virtual u_int32_t GetSamplesPerFrame() = 0;
+
+ virtual bool EncodeSamples(
+ int16_t* pSamples,
+ u_int32_t numSamplesPerChannel,
+- u_int8_t numChannels) = NULL;
++ u_int8_t numChannels) = 0;
+
+ virtual bool GetEncodedFrame(
+ u_int8_t** ppBuffer,
+ u_int32_t* pBufferLength,
+- u_int32_t* pNumSamplesPerChannel) = NULL;
++ u_int32_t* pNumSamplesPerChannel) = 0;
+
+
+ // utility routines
+diff -ur mpeg4ip-1.1/server/mp4live/media_codec.h mpeg4ip.new/server/mp4live/media_codec.h
+--- mpeg4ip-1.1/server/mp4live/media_codec.h 2002-10-30 20:12:37.000000000 +0100
++++ mpeg4ip.new/server/mp4live/media_codec.h 2004-10-02 13:10:14.000000000 +0200
+@@ -33,11 +33,11 @@
+ m_pConfig = NULL;
+ }
+
+- virtual MediaType GetFrameType(void) = NULL;
++ virtual MediaType GetFrameType(void) = 0;
+
+- virtual bool Init(CLiveConfig* pConfig, bool realTime = true) = NULL;
++ virtual bool Init(CLiveConfig* pConfig, bool realTime = true) = 0;
+
+- virtual void Stop() = NULL;
++ virtual void Stop() = 0;
+
+ protected:
+ CLiveConfig* m_pConfig;
+diff -ur mpeg4ip-1.1/server/mp4live/media_flow.h mpeg4ip.new/server/mp4live/media_flow.h
+--- mpeg4ip-1.1/server/mp4live/media_flow.h 2004-01-01 00:00:36.000000000 +0100
++++ mpeg4ip.new/server/mp4live/media_flow.h 2004-10-02 13:09:30.000000000 +0200
+@@ -38,9 +38,9 @@
+ m_started = false;
+ }
+
+- virtual void Start() = NULL;
++ virtual void Start() = 0;
+
+- virtual void Stop() = NULL;
++ virtual void Stop() = 0;
+
+ void SetConfig(CLiveConfig* pConfig) {
+ m_pConfig = pConfig;
+diff -ur mpeg4ip-1.1/server/mp4live/media_node.h mpeg4ip.new/server/mp4live/media_node.h
+--- mpeg4ip-1.1/server/mp4live/media_node.h 2004-02-20 01:34:43.000000000 +0100
++++ mpeg4ip.new/server/mp4live/media_node.h 2004-10-02 13:08:49.000000000 +0200
+@@ -83,7 +83,7 @@
+ static const uint32_t MSG_NODE_STOP = MSG_NODE + 2;
+ static const uint32_t MSG_NODE_STOP_THREAD = MSG_NODE + 3;
+
+- virtual int ThreadMain(void) = NULL;
++ virtual int ThreadMain(void) = 0;
+
+ protected:
+ SDL_Thread* m_myThread;
+diff -ur mpeg4ip-1.1/server/mp4live/media_source.h mpeg4ip.new/server/mp4live/media_source.h
+--- mpeg4ip-1.1/server/mp4live/media_source.h 2004-03-15 23:47:01.000000000 +0100
++++ mpeg4ip.new/server/mp4live/media_source.h 2004-10-02 13:09:14.000000000 +0200
+@@ -63,11 +63,11 @@
+ NULL, 0, m_myMsgQueueSemaphore);
+ }
+
+- virtual bool IsDone() = NULL;
++ virtual bool IsDone() = 0;
+
+ virtual Duration GetElapsedDuration();
+
+- virtual float GetProgress() = NULL;
++ virtual float GetProgress() = 0;
+
+ virtual u_int32_t GetNumEncodedVideoFrames() {
+ return m_videoEncodedFrames;
+diff -ur mpeg4ip-1.1/server/mp4live/video_encoder.h mpeg4ip.new/server/mp4live/video_encoder.h
+--- mpeg4ip-1.1/server/mp4live/video_encoder.h 2004-04-08 20:07:39.000000000 +0200
++++ mpeg4ip.new/server/mp4live/video_encoder.h 2004-10-02 13:11:47.000000000 +0200
+@@ -31,21 +31,21 @@
+ public:
+ CVideoEncoder() { };
+
+- virtual bool Init(CLiveConfig *pConfig, bool realTime = true) = NULL;
++ virtual bool Init(CLiveConfig *pConfig, bool realTime = true) = 0;
+
+ virtual bool EncodeImage(
+ u_int8_t* pY, u_int8_t* pU, u_int8_t* pV,
+ u_int32_t yStride, u_int32_t uvStride,
+ bool wantKeyFrame,
+ Duration elapsedDuration,
+- Timestamp srcFrameTimestamp) = NULL;
++ Timestamp srcFrameTimestamp) = 0;
+
+ virtual bool GetEncodedImage(
+ u_int8_t** ppBuffer, u_int32_t* pBufferLength,
+- Timestamp *dts, Timestamp *pts) = NULL;
++ Timestamp *dts, Timestamp *pts) = 0;
+
+ virtual bool GetReconstructedImage(
+- u_int8_t* pY, u_int8_t* pU, u_int8_t* pV) = NULL;
++ u_int8_t* pY, u_int8_t* pU, u_int8_t* pV) = 0;
+ virtual media_free_f GetMediaFreeFunction(void) { return NULL; };
+
+ virtual bool CanGetEsConfig (void) { return false; };
+diff -ur mpeg4ip-1.1/server/mp4live/video_util_filter.cpp mpeg4ip.new/server/mp4live/video_util_filter.cpp
+--- mpeg4ip-1.1/server/mp4live/video_util_filter.cpp 2004-01-23 23:21:58.000000000 +0100
++++ mpeg4ip.new/server/mp4live/video_util_filter.cpp 2004-10-02 18:50:10.336818840 +0200
+@@ -83,7 +83,7 @@
+ // error_message("mmx");
+ asm volatile(
+ "leal (%0, %1), %%eax \n\t"
+- "leal (%%eax, %1, 4), %%ebx \n\t"
++ "leal (%%eax, %1, 4), %%ecx \n\t"
+
+ "movq (%0), %%mm0 \n\t" // L0
+ "movq (%%eax, %1), %%mm1 \n\t" // L2
+@@ -99,31 +99,31 @@
+ PAVGB(%%mm2, %%mm1) // L2+L4
+ PAVGB(%%mm0, %%mm1) // 2L3 + L2 + L4
+ "movq %%mm1, (%%eax, %1) \n\t"
+- "movq (%%ebx), %%mm1 \n\t" // L5
++ "movq (%%ecx), %%mm1 \n\t" // L5
+ PAVGB(%%mm1, %%mm0) // L3+L5
+ PAVGB(%%mm2, %%mm0) // 2L4 + L3 + L5
+ "movq %%mm0, (%%eax, %1, 2) \n\t"
+- "movq (%%ebx, %1), %%mm0 \n\t" // L6
++ "movq (%%ecx, %1), %%mm0 \n\t" // L6
+ PAVGB(%%mm0, %%mm2) // L4+L6
+ PAVGB(%%mm1, %%mm2) // 2L5 + L4 + L6
+ "movq %%mm2, (%0, %1, 4) \n\t"
+- "movq (%%ebx, %1, 2), %%mm2 \n\t" // L7
++ "movq (%%ecx, %1, 2), %%mm2 \n\t" // L7
+
+
+ PAVGB(%%mm2, %%mm1) // L5+L7
+ PAVGB(%%mm0, %%mm1) // 2L6 + L5 + L7
+- "movq %%mm1, (%%ebx) \n\t"
++ "movq %%mm1, (%%ecx) \n\t"
+ "movq (%0, %1, 8), %%mm1 \n\t" // L8
+ PAVGB(%%mm1, %%mm0) // L6+L8
+ PAVGB(%%mm2, %%mm0) // 2L7 + L6 + L8
+- "movq %%mm0, (%%ebx, %1) \n\t"
+- "movq (%%ebx, %1, 4), %%mm0 \n\t" // L9
++ "movq %%mm0, (%%ecx, %1) \n\t"
++ "movq (%%ecx, %1, 4), %%mm0 \n\t" // L9
+ PAVGB(%%mm0, %%mm2) // L7+L9
+ PAVGB(%%mm1, %%mm2) // 2L8 + L7 + L9
+- "movq %%mm2, (%%ebx, %1, 2) \n\t"
++ "movq %%mm2, (%%ecx, %1, 2) \n\t"
+
+ : : "r" (src), "r" (stride)
+- : "%eax", "%ebx"
++ : "%eax", "%ecx"
+ );
+ emms();
+ #else
diff --git a/media-video/mpeg4ip/files/mpeg4ip-1.1-gentoo-fixes.patch b/media-video/mpeg4ip/files/mpeg4ip-1.1-gentoo-fixes.patch
new file mode 100644
index 000000000000..eeaffd571175
--- /dev/null
+++ b/media-video/mpeg4ip/files/mpeg4ip-1.1-gentoo-fixes.patch
@@ -0,0 +1,22 @@
+--- lib/rtp/net_udp.c.orig 2004-11-05 14:04:46.417284144 -0500
++++ lib/rtp/net_udp.c 2004-11-05 14:04:50.513661400 -0500
+@@ -444,7 +444,7 @@
+ if (inet_aton(G_Multicast_Src, &imr.imr_sourceaddr) == 0) {
+ rtp_message(LOG_ERR, "inet_aton failed for %s\n",
+ G_Multicast_Src);
+- abort;
++ abort();
+ }
+ if( setsockopt( s->fd, IPPROTO_IP, IP_DROP_SOURCE_MEMBERSHIP,
+ (char*)&imr,
+--- server/mp4live/gui/gui_utils.cpp.orig 2004-11-05 14:08:09.002486512 -0500
++++ server/mp4live/gui/gui_utils.cpp 2004-11-05 14:08:10.505258056 -0500
+@@ -352,7 +352,7 @@
+ {
+ char buffer[80];
+
+- sprintf(buffer, "%u", value);
++ sprintf(buffer, "%lu",(unsigned long int)value);
+ gtk_entry_set_text(GTK_ENTRY(entry), buffer);
+ }
+
diff --git a/media-video/mpeg4ip/mpeg4ip-1.1.ebuild b/media-video/mpeg4ip/mpeg4ip-1.1.ebuild
index 5bc6673735e9..32d6d7dd7ae5 100644
--- a/media-video/mpeg4ip/mpeg4ip-1.1.ebuild
+++ b/media-video/mpeg4ip/mpeg4ip-1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/mpeg4ip-1.1.ebuild,v 1.7 2004/07/26 04:04:52 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/mpeg4ip-1.1.ebuild,v 1.8 2004/11/06 00:16:23 tester Exp $
+
+inherit eutils
DESCRIPTION="MPEG 4 implementation library"
@@ -29,7 +31,7 @@ RDEPEND="sys-devel/libtool
arts? ( kde-base/arts )
esd? ( media-sound/esound )"
-DEPENDS="${RDEPEND}
+DEPEND="${RDEPEND}
x86? ( mmx? ( >=dev-lang/nasm-0.98.19 ) )"
src_unpack() {
@@ -39,6 +41,10 @@ src_unpack() {
cd ${S}/lib/SDLAudio
sed -i -e 's:-laudio:-L/usr/X11R6/lib -laudio:' configure
+
+ cd ${S}
+ #epatch ${FILESDIR}/mpeg4ip-1.1-gcc3.4.patch
+ epatch ${FILESDIR}/mpeg4ip-1.1-gentoo-fixes.patch
}
src_compile() {