summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-18 16:37:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-18 16:37:19 +0000
commitd6876f0f63c901fda29417a9f05e51e876dde7db (patch)
tree3503d4e4f02557a44c449c24a5b4645f79896c1b /games-puzzle/amoebax/amoebax-0.2.0.ebuild
parentStable on amd64 wrt bug #341333 (diff)
downloadhistorical-d6876f0f63c901fda29417a9f05e51e876dde7db.tar.gz
historical-d6876f0f63c901fda29417a9f05e51e876dde7db.tar.bz2
historical-d6876f0f63c901fda29417a9f05e51e876dde7db.zip
Add use deps; fix desktop file; tidy
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-puzzle/amoebax/amoebax-0.2.0.ebuild')
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.0.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/games-puzzle/amoebax/amoebax-0.2.0.ebuild b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
index 53f196342b8f..f73bf76502ef 100644
--- a/games-puzzle/amoebax/amoebax-0.2.0.ebuild
+++ b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.7 2010/01/09 18:59:58 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.8 2010/10/18 16:37:19 mr_bones_ Exp $
EAPI=2
inherit autotools eutils games
@@ -14,10 +14,9 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-mixer"
-DEPEND="${RDEPEND}"
+DEPEND="media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
src_prepare() {
epatch \
@@ -26,13 +25,15 @@ src_prepare() {
"${FILESDIR}"/${P}-aclocal.patch
sed -i \
-e "/^SUBDIRS/s:doc ::" \
- Makefile.am \
- || die "sed failed"
+ Makefile.am || die
sed -i \
-e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
-e "/^desktopdir/s:=.*:=/usr/share/applications:" \
- data/Makefile.am \
- || die "sed failed"
+ data/Makefile.am || die
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s/.svg//' \
+ data/amoebax.desktop || die
AT_M4DIR=m4 eautoreconf
}