summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 10:07:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 10:07:08 +0000
commita13b66bb1284fa6e78a0a54f4bfe1b327ca42ace (patch)
tree6414f3254da973ee6d2d9aed0ad19d2bfebff75b /dev-util/strace
parentgnutls is global now (diff)
downloadhistorical-a13b66bb1284fa6e78a0a54f4bfe1b327ca42ace.tar.gz
historical-a13b66bb1284fa6e78a0a54f4bfe1b327ca42ace.tar.bz2
historical-a13b66bb1284fa6e78a0a54f4bfe1b327ca42ace.zip
Add a temp workaround to alpha stat64 issues.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog6
-rw-r--r--dev-util/strace/Manifest5
-rw-r--r--dev-util/strace/files/strace-4.5.11-alpha-stat64.patch37
-rw-r--r--dev-util/strace/strace-4.5.11.ebuild5
4 files changed, 49 insertions, 4 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 28a724cd2a2f..85ea2969d6aa 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.62 2005/05/24 00:29:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.63 2005/05/28 10:07:08 vapier Exp $
+
+ 28 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/strace-4.5.11-alpha-stat64.patch, strace-4.5.11.ebuild:
+ Add a temp workaround to alpha stat64 issues.
*strace-4.5.11 (24 May 2005)
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index d55fed229bd3..bffe229ea46e 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,6 +1,6 @@
-MD5 4c547d03b7565c0b33b27f0926afd36d ChangeLog 7232
+MD5 aa0449f1b59c5775db3f5922969419cc ChangeLog 7396
MD5 c9d8ca6c43099729a9c981ed49e94ce3 strace-4.5.9.ebuild 1429
-MD5 f3283c424c4d5d35e5ce6a677749b7f6 strace-4.5.11.ebuild 1584
+MD5 fe3c4c919829c11cd9d99380d984dd06 strace-4.5.11.ebuild 1677
MD5 85f383eadb2ed8c50c1a494e679bd2a2 strace-4.5.1.ebuild 1294
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 7a45d471b2608afbcfac7b22f86726ce strace-4.5.7.ebuild 1139
@@ -14,3 +14,4 @@ MD5 3eb9b0a09aef20e2fd45e7f6e73557d1 files/strace-4.5.11-fbsd.patch 4767
MD5 332b30ad46b6f4ee72387a779580f321 files/digest-strace-4.5.7 65
MD5 b2d46a601a4bd117795f40178cf40612 files/digest-strace-4.5.2 65
MD5 3d30271a2e23ac6401b2b54f99b91e5c files/strace-4.5.2-s390-april2004.diff 11986
+MD5 cbd6857cb3c5b57e1364ca621fb1a5b3 files/strace-4.5.11-alpha-stat64.patch 1418
diff --git a/dev-util/strace/files/strace-4.5.11-alpha-stat64.patch b/dev-util/strace/files/strace-4.5.11-alpha-stat64.patch
new file mode 100644
index 000000000000..e55f61d1f682
--- /dev/null
+++ b/dev-util/strace/files/strace-4.5.11-alpha-stat64.patch
@@ -0,0 +1,37 @@
+Hack around an ugly issue. The only arch to provide the st_flags and st_gen
+members of the stat structure is alpha. However, alpha only provides it for
+stat and not stat64. So the autoconf script checks the stat structure for
+all the relevant members but does not check stat64, thus setting up defines
+that say these two members are present. To make matters worse, glibc defines
+(via sys/stat.h -> bits/stat.h) both stat and stat64 with the st_flags and
+st_gen members. Since file.c makes sure to hide the glibc defines and use the
+kernel defines, even if we tried to detect stat64.st_flags and stat64.st_gen
+in the autoconf script, the glibc headers would be parsed thereforce providing
+false positives.
+
+--- file.c
++++ file.c
+@@ -997,13 +997,6 @@
+ tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime));
+ tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime));
+ tprintf("st_ctime=%s", sprinttime(statbuf.st_ctime));
+-#if HAVE_STRUCT_STAT_ST_FLAGS
+- tprintf(", st_flags=");
+- if (statbuf.st_flags) {
+- printflags(fileflags, statbuf.st_flags);
+- } else
+- tprintf("0");
+-#endif
+ #if HAVE_STRUCT_STAT_ST_ACLCNT
+ tprintf(", st_aclcnt=%d", statbuf.st_aclcnt);
+ #endif
+@@ -1014,9 +1007,6 @@
+ tprintf(", st_fstype=%.*s",
+ (int) sizeof statbuf.st_fstype, statbuf.st_fstype);
+ #endif
+-#if HAVE_STRUCT_STAT_ST_GEN
+- tprintf(", st_gen=%u", statbuf.st_gen);
+-#endif
+ tprintf("}");
+ }
+ else
diff --git a/dev-util/strace/strace-4.5.11.ebuild b/dev-util/strace/strace-4.5.11.ebuild
index e6af2728b8b6..22bfc85ed1a8 100644
--- a/dev-util/strace/strace-4.5.11.ebuild
+++ b/dev-util/strace/strace-4.5.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.11.ebuild,v 1.2 2005/05/25 00:22:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.11.ebuild,v 1.3 2005/05/28 10:07:08 vapier Exp $
inherit flag-o-matic
@@ -24,6 +24,9 @@ src_unpack() {
aclocal && autoconf && automake || die "autotools failed"
fi
+ # Hack until we can fix this properly
+ epatch ${FILESDIR}/strace-4.5.11-alpha-stat64.patch
+
# Remove some obsolete ia64-related hacks from the strace source
# (08 Feb 2005 agriffis)
epatch ${FILESDIR}/strace-4.5.8-ia64.patch