summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-11-05 13:58:23 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-11-05 13:58:23 +0000
commita50cbd224efba8489640b4949782ed61af7da25d (patch)
treeae50b787ab263ae98301e2ab64e131cebfee734e /dev-util/git
parentAdd ~sparc keyword --- Bug #154084 (diff)
downloadhistorical-a50cbd224efba8489640b4949782ed61af7da25d.tar.gz
historical-a50cbd224efba8489640b4949782ed61af7da25d.tar.bz2
historical-a50cbd224efba8489640b4949782ed61af7da25d.zip
New upstream version.
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.3.49
-rw-r--r--dev-util/git/git-1.4.3.4.ebuild151
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index ecd51856ef23..da3a041befd1 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.140 2006/10/30 10:41:26 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.141 2006/11/05 13:58:23 ferdy Exp $
+
+*git-1.4.3.4 (05 Nov 2006)
+
+ 05 Nov 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.3.3.ebuild,
+ +git-1.4.3.4.ebuild:
+ New upstream version.
*git-1.4.3.3 (30 Oct 2006)
diff --git a/dev-util/git/files/digest-git-1.4.3.4 b/dev-util/git/files/digest-git-1.4.3.4
new file mode 100644
index 000000000000..f7dbb31b4960
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.3.4
@@ -0,0 +1,9 @@
+MD5 5114c6b58329f3574697a595774df7d0 git-1.4.3.4.tar.bz2 859033
+RMD160 eaa8d066ff5f1d18e733da6be435e54b5a916626 git-1.4.3.4.tar.bz2 859033
+SHA256 08b842e62019b7fca5e659e1d65807707a3bef5207b0ca65d85b840b5599a318 git-1.4.3.4.tar.bz2 859033
+MD5 65171c76b51ecf684f3f697f1547e72e git-htmldocs-1.4.3.4.tar.bz2 305714
+RMD160 627fc695081eca3efcbfe6f7b945e528fc08f1d2 git-htmldocs-1.4.3.4.tar.bz2 305714
+SHA256 e378a0adf19b7fb6352eb9aa5df414f02bf4c4129b448dad4db647158db858d6 git-htmldocs-1.4.3.4.tar.bz2 305714
+MD5 10194e544e9654500474d3167855d89a git-manpages-1.4.3.4.tar.bz2 98021
+RMD160 fdc3bf7ca64695f87ebf845e3a4abeafa9105b8c git-manpages-1.4.3.4.tar.bz2 98021
+SHA256 f5f06a744d920910b30c6e959d173b0c96bbf4fe5764d54bae348c118c653269 git-manpages-1.4.3.4.tar.bz2 98021
diff --git a/dev-util/git/git-1.4.3.4.ebuild b/dev-util/git/git-1.4.3.4.ebuild
new file mode 100644
index 000000000000..8dae0272d0b5
--- /dev/null
+++ b/dev-util/git/git-1.4.3.4.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.3.4.ebuild,v 1.1 2006/11/05 13:58:23 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ einfo " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo "These additional scripts need some dependencies:"
+ einfo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dep-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}