summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-25 20:18:02 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-25 20:18:02 +0000
commit7a3c7040b8daf898c1de1dbc357fe6af51bcb63a (patch)
tree3a4c76db1ca27bfc0b6e126103bc74460a41ff8b /dev-util/ccache
parentbeta6 is a bugfix for beta5 (diff)
downloadhistorical-7a3c7040b8daf898c1de1dbc357fe6af51bcb63a.tar.gz
historical-7a3c7040b8daf898c1de1dbc357fe6af51bcb63a.tar.bz2
historical-7a3c7040b8daf898c1de1dbc357fe6af51bcb63a.zip
fixes for ccache ebuilds; see bug 15100
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog9
-rw-r--r--dev-util/ccache/ccache-2.1.1-r2.ebuild10
-rw-r--r--dev-util/ccache/ccache-2.1.1.ebuild7
3 files changed, 20 insertions, 6 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index d736cea26903..c9c0344e7249 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.16 2003/02/25 04:40:04 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.17 2003/02/25 20:18:02 zwelch Exp $
*ccache-2.1.1-r2 (24 Feb 2003)
+ 25 Feb 2003; Zach Welch <zwelch@gentoo.org> ccache-2.1.1-r2.ebuild :
+ Remove old versions outright, don't backup; fixes multiple re-installs
+ Add portage 2.0.46-r11 as a RDEPEND.
+
24 Feb 2003; Zach Welch <zwelch@gentoo.org> ccache-2.1.1-r2.ebuild :
Add missing keepdir; no bump since found fast
@@ -15,6 +19,9 @@
*ccache-2.1.1 (24 Jan 2002)
+ 25 Feb 2003; Zach Welch <zwelch@gentoo.org> ccache-2.1.1-r2.ebuild ccache-2.1.1.ebuild :
+ Fix ccache-2.1.1 ebuild to allow downgrade from 2.1.1-r2
+
24 Jan 2002; Bart Verwilst <verwilst@gentoo.org> : updating to 2.1.1.
06 Jan 2003; Jan Seidel <tuxus@gentoo.org>: ccache-1.9-r1.ebuild,
diff --git a/dev-util/ccache/ccache-2.1.1-r2.ebuild b/dev-util/ccache/ccache-2.1.1-r2.ebuild
index d78ff78a2853..485f418fb894 100644
--- a/dev-util/ccache/ccache-2.1.1-r2.ebuild
+++ b/dev-util/ccache/ccache-2.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.1.1-r2.ebuild,v 1.2 2003/02/25 04:40:04 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.1.1-r2.ebuild,v 1.3 2003/02/25 20:18:02 zwelch Exp $
DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
compiler to safely cache compilation output. When the same code is compiled
@@ -12,7 +12,8 @@ IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha arm"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc \
+ >=sys-apps/portage-2.0.46-r11"
# Note: this version is designed to be auto-detected and used if
# you happen to have Portage 2.0.X+ installed.
@@ -42,7 +43,8 @@ src_install () {
pkg_preinst() {
# Portage doesn't handle replacing a non-empty dir with a file!
- test -d /usr/bin/ccache && mv -f /usr/bin/ccache /usr/bin/ccache.backup
+ [ -e /usr/bin/ccache ] && rm -rf /usr/bin/ccache
+ [ -e /usr/bin/ccache.backup ] && rm -rf /usr/bin/ccache.backup
}
pkg_postinst() {
@@ -62,7 +64,7 @@ pkg_postinst() {
einfo "/usr/lib/ccache/bin to your path before /usr/bin. Portage 2.0.X+"
einfo "will automatically take advantage of ccache with no additional"
einfo "steps. If this is your first install of ccache, type something"
- einfo "like this to set a maximum cache size of 2GB (or similar)"
+ einfo "like this to set a maximum cache size of 2GB (or similar):"
einfo "# ccache -M 2G"
}
diff --git a/dev-util/ccache/ccache-2.1.1.ebuild b/dev-util/ccache/ccache-2.1.1.ebuild
index 6a06c8f9d75a..dcc051239d06 100644
--- a/dev-util/ccache/ccache-2.1.1.ebuild
+++ b/dev-util/ccache/ccache-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.1.1.ebuild,v 1.3 2003/02/13 11:47:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.1.1.ebuild,v 1.4 2003/02/25 20:18:02 zwelch Exp $
DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
compiler to safely cache compilation output. When the same code is compiled
@@ -27,6 +27,11 @@ src_install () {
dodoc COPYING README
}
+pkg_preinst() {
+ [ -e /usr/bin/ccache ] && rm -rf /usr/bin/ccache
+ [ -e /usr/bin/ccache.backup ] && rm -rf /usr/bin/ccache.backup
+}
+
pkg_postinst() {
cd /usr/bin/ccache