summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-02-03 22:00:12 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-02-03 22:00:12 +0000
commit197754b424314bccd018d9461e54d59b6445b845 (patch)
treefc15530d718d9b87ef0d203a7c10521614f5991c /dev-ruby/redcloth
parentFixed minor issue with the README file's location (diff)
downloadhistorical-197754b424314bccd018d9461e54d59b6445b845.tar.gz
historical-197754b424314bccd018d9461e54d59b6445b845.tar.bz2
historical-197754b424314bccd018d9461e54d59b6445b845.zip
Version bump.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog7
-rw-r--r--dev-ruby/redcloth/Manifest10
-rw-r--r--dev-ruby/redcloth/files/digest-redcloth-3.0.21
-rw-r--r--dev-ruby/redcloth/redcloth-3.0.2.ebuild32
4 files changed, 45 insertions, 5 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index f8d91c233bf7..736c04f434f9 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.1 2005/01/26 16:32:31 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.2 2005/02/03 22:00:12 citizen428 Exp $
+
+*redcloth-3.0.2 (03 Feb 2005)
+
+ 03 Feb 2005; Michael Kohl <citizen428@gentoo.org> +redcloth-3.0.2.ebuild:
+ Version bump.
*redcloth-3.0.1 (26 Jan 2005)
diff --git a/dev-ruby/redcloth/Manifest b/dev-ruby/redcloth/Manifest
index ae5291622306..5fd794e32876 100644
--- a/dev-ruby/redcloth/Manifest
+++ b/dev-ruby/redcloth/Manifest
@@ -2,13 +2,15 @@
Hash: SHA1
MD5 e73ce9a8d885605f369398315d2ef4b5 redcloth-3.0.1.ebuild 914
-MD5 6c949246a655bf1aa7011737d88aadcc ChangeLog 405
+MD5 20086e9ad5e9f2e6e2e7a2adc01cc5e3 ChangeLog 529
MD5 1a24e0b48460c02e20931fceded24e1a metadata.xml 254
+MD5 c4913327a220d4082973bbdbf0fede9f redcloth-3.0.2.ebuild 914
MD5 21377cbdd036ae765522479d45792805 files/digest-redcloth-3.0.1 65
+MD5 b9838cf4682185a89eca06878760ad48 files/digest-redcloth-3.0.2 65
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFB98Yp/UDVUK2NELYRAkK7AKDWJxC4Ywb++sv4kLziLBt+2/mO8wCfRxo1
-X5G0T6JhuRJL/Z0h3x8PzNQ=
-=Xkgi
+iD8DBQFCAp76/UDVUK2NELYRAoJtAKC0yLbVBALfOLjAkDzAObajU0wxgwCgw4Xb
+fA4ShMq6B6Si7lQsm775d1g=
+=F0Zp
-----END PGP SIGNATURE-----
diff --git a/dev-ruby/redcloth/files/digest-redcloth-3.0.2 b/dev-ruby/redcloth/files/digest-redcloth-3.0.2
new file mode 100644
index 000000000000..1c11caa9683f
--- /dev/null
+++ b/dev-ruby/redcloth/files/digest-redcloth-3.0.2
@@ -0,0 +1 @@
+MD5 12997c80e10316ef7765a43a6c9b43e8 RedCloth-3.0.2.tar.gz 36864
diff --git a/dev-ruby/redcloth/redcloth-3.0.2.ebuild b/dev-ruby/redcloth/redcloth-3.0.2.ebuild
new file mode 100644
index 000000000000..cfb4a02979b8
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.2.ebuild,v 1.1 2005/02/03 22:00:12 citizen428 Exp $
+
+inherit ruby
+
+MY_P="RedCloth-${PV}"
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://www.whytheluckystiff.net/ruby/redcloth/"
+SRC_URI="http://rubyforge.org/frs/download.php/2852/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+USE_RUBY="any"
+DEPEND="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die "ruby install.rb config failed"
+ ruby install.rb setup || die "ruby install.rb setup failed"
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die "ruby install.rb config failed"
+ ruby install.rb install || die "ruby install.rb install failed"
+ dodoc doc/CHANGELOG doc/README doc/REFERENCE
+}