summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
commit2c60fb5f6269740fedf62906788b349731bd48ce (patch)
tree601abc746999c8caaa40479c345df64fafca0401 /dev-lang/ocaml
parentocaml latex use flag (diff)
downloadhistorical-2c60fb5f6269740fedf62906788b349731bd48ce.tar.gz
historical-2c60fb5f6269740fedf62906788b349731bd48ce.tar.bz2
historical-2c60fb5f6269740fedf62906788b349731bd48ce.zip
Fix bug #50028.
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/Manifest8
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r2.ebuild10
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild9
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild8
5 files changed, 30 insertions, 11 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 74c4b5834c3e..f30019d13c7f 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.40 2004/08/08 07:53:44 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.41 2004/08/08 09:06:00 mattam Exp $
+
+ 08 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.06-r2.ebuild,
+ ocaml-3.07-r1.ebuild, ocaml-3.08.ebuild:
+ Add support for ocamldoc and latex via a new use flag.
*ocaml-3.08 (08 Aug 2004)
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index 99b7f22a1ef5..b07b308f4c34 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,8 +1,8 @@
-MD5 d3109bd8d52604b97f98cf9e203f3707 ChangeLog 6898
+MD5 d4d96c9d07aaba0aa3f9ffe4bcc24e06 ChangeLog 7072
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
-MD5 5caaff592069914b134a83a6752ec138 ocaml-3.06-r2.ebuild 1543
-MD5 64432ef54108899425565cf0a88cba54 ocaml-3.07-r1.ebuild 2473
-MD5 e80d49edf0616c356a022ad7cbdaf07c ocaml-3.08.ebuild 1769
+MD5 a345c82ec2955b8bd3d3bbe3fadabe62 ocaml-3.06-r2.ebuild 1660
+MD5 cd172d41f584226fac22e50ff6c991a8 ocaml-3.07-r1.ebuild 2570
+MD5 7ff1ed27aaccdd98b73f37d2cc3dbfd9 ocaml-3.08.ebuild 1868
MD5 d996b9a852fbfcb0c2d9bddb4896add2 files/ocaml-rebuild.sh 1228
MD5 77519cb4017543f060a963387b593299 files/digest-ocaml-3.08 65
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
diff --git a/dev-lang/ocaml/ocaml-3.06-r2.ebuild b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
index d4705ffa6848..470e147c5f71 100644
--- a/dev-lang/ocaml/ocaml-3.06-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.7 2004/07/06 20:51:30 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.8 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 sparc ppc alpha"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -62,3 +62,9 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+} \ No newline at end of file
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index dd699dcffc86..8cfb36853926 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.19 2004/07/27 13:14:34 alexander Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.20 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -13,7 +13,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa ~macos"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -81,6 +81,11 @@ pkg_postinst() {
ranlib /usr/lib/ocaml/stdlib.a
ranlib /usr/lib/ocaml/libasmrun.a
+
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
index b9831707c267..867c26c8ea10 100644
--- a/dev-lang/ocaml/ocaml-3.08.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.1 2004/08/08 07:53:44 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.2 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-3.08/${P}.0.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64 ~amd64 ~hppa ~macos"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -60,6 +60,10 @@ src_install() {
pkg_postinst() {
ranlib /usr/lib/ocaml/*.a
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"