summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-04-24 16:04:21 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-04-24 16:04:21 +0000
commit592b91daa146c34be5a118580ef319abbc0ea93a (patch)
treee8f0cf3df1d9ac168bca464398a83e292ab221fa /dev-lang/nhc98
parentversion bump and changed to use mirror: (diff)
downloadhistorical-592b91daa146c34be5a118580ef319abbc0ea93a.tar.gz
historical-592b91daa146c34be5a118580ef319abbc0ea93a.tar.bz2
historical-592b91daa146c34be5a118580ef319abbc0ea93a.zip
removed hmake-related files from nhc98 package, because they are in a separate ebuild now
Diffstat (limited to 'dev-lang/nhc98')
-rw-r--r--dev-lang/nhc98/ChangeLog10
-rw-r--r--dev-lang/nhc98/files/digest-nhc98-1.16-r12
-rw-r--r--dev-lang/nhc98/nhc98-1.16-r1.ebuild70
3 files changed, 80 insertions, 2 deletions
diff --git a/dev-lang/nhc98/ChangeLog b/dev-lang/nhc98/ChangeLog
index 81a1e25e92bc..2cd7cea8ed69 100644
--- a/dev-lang/nhc98/ChangeLog
+++ b/dev-lang/nhc98/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for dev-lang/nhc98
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/ChangeLog,v 1.7 2003/04/16 08:39:51 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/ChangeLog,v 1.8 2003/04/24 16:04:21 kosmikus Exp $
+
+*nhc98-1.16-r1 (24 Apr 2003)
+
+ 24 Apr 2003; Andres Loeh <kosmikus@gentoo.org> nhc98-1.16-r1.ebuild:
+ Removed hmake from the nhc98 ebuild; hmake is now a separate package
+ (dev-haskell/hmake)
*nhc98-1.16 (09 Apr 2003)
- 16 Apr 2003; Andres Loeh <andres@gentoo.org> nhc98-1.16.ebuild:
+ 16 Apr 2003; Andres Loeh <kosmikus@gentoo.org> nhc98-1.16.ebuild:
Cleaned up the ebuild, moving hmake configuration to postinst, see #18857
09 Apr 2003; George Shapovalov <george@gentoo.org> all :
diff --git a/dev-lang/nhc98/files/digest-nhc98-1.16-r1 b/dev-lang/nhc98/files/digest-nhc98-1.16-r1
new file mode 100644
index 000000000000..e3dbcc015c5d
--- /dev/null
+++ b/dev-lang/nhc98/files/digest-nhc98-1.16-r1
@@ -0,0 +1,2 @@
+MD5 a62866b8d966108cba325d0322a3010d nhc98src-1.16.tar.gz 5689485
+MD5 38b1505acbcbc5a91e077304e978ab82 patch-1.16-typesyn 5700
diff --git a/dev-lang/nhc98/nhc98-1.16-r1.ebuild b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
new file mode 100644
index 000000000000..58dd4d54f593
--- /dev/null
+++ b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16-r1.ebuild,v 1.1 2003/04/24 16:04:21 kosmikus Exp $
+
+IUSE="readline"
+
+TARBALL="nhc98src-${PV}.tar.gz"
+
+DESCRIPTION="Haskell 98 compiler"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+
+SLOT="0"
+LICENSE="nhc98"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1 )"
+
+src_unpack() {
+ # unpack the source
+ unpack "${TARBALL}"
+ # type synoym patch
+ cd ${S}
+ epatch ${DISTDIR}/patch-1.16-typesyn
+# cd ${P}
+# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
+}
+
+src_compile() {
+
+ ./configure --buildwith=gcc \
+ --prefix=/usr --installdir=/usr \
+ -man -docs \
+ --buildopts="${CFLAGS} --host=${CHOST}" || die "./configure failed"
+ # the build does not seem to work all that
+ # well with parallel make
+ make || die
+}
+
+src_install () {
+ # The install location is taken care of by the
+ # configure script.
+ make DESTDIR=${D} install || die
+
+ #install docs and man pages manually
+ dodoc README INSTALL COPYRIGHT
+ doman man/*
+
+ cd docs
+ dohtml -A hs -r *
+ docinto html/bugs
+ dodoc bugs/README
+
+ # Manually remove everything hmake-specific.
+ # hmake has its own package and thus should not be
+ # overwritten by nhc98. It might be considered
+ # to make nhc98 PDEPEND on hmake, though ...
+ rm ${D}/usr/bin/hmake*
+ rm ${D}/usr/bin/{harch,hi}
+ rm -rf ${D}/usr/lib/hmake
+ rm ${D}/usr/share/man/man1/hmake*
+}
+
+pkg_postinst () {
+ # info about new package structure
+ einfo "NOTICE: hmake is no longer a part of this package,"
+ einfo "but separately available as dev-haskell/hmake."
+}