summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-07-14 22:11:35 +0000
committerVlastimil Babka <caster@gentoo.org>2008-07-14 22:11:35 +0000
commit59109f8d9cf54eba24dce75516c6622c3049e66e (patch)
tree26f6ebd1cdf35e40b3d46025f9c17f299b984f0a /dev-java/ant-junit
parentCopy local USE flags from ant-tasks to ant for 1.7.1. (diff)
downloadhistorical-59109f8d9cf54eba24dce75516c6622c3049e66e.tar.gz
historical-59109f8d9cf54eba24dce75516c6622c3049e66e.tar.bz2
historical-59109f8d9cf54eba24dce75516c6622c3049e66e.zip
Version bump, bug #231776.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64
Diffstat (limited to 'dev-java/ant-junit')
-rw-r--r--dev-java/ant-junit/ChangeLog9
-rw-r--r--dev-java/ant-junit/ant-junit-1.7.1.ebuild24
2 files changed, 31 insertions, 2 deletions
diff --git a/dev-java/ant-junit/ChangeLog b/dev-java/ant-junit/ChangeLog
index 5677b6dc9a51..9d77e4ca09c5 100644
--- a/dev-java/ant-junit/ChangeLog
+++ b/dev-java/ant-junit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-junit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit/ChangeLog,v 1.9 2007/05/12 18:16:10 wltjr Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit/ChangeLog,v 1.10 2008/07/14 21:59:18 caster Exp $
+
+*ant-junit-1.7.1 (14 Jul 2008)
+
+ 14 Jul 2008; Vlastimil Babka <caster@gentoo.org> +ant-junit-1.7.1.ebuild:
+ Version bump, bug #231776.
12 May 2007; William L. Thomson Jr. <wltjr@gentoo.org>
ant-junit-1.7.0.ebuild:
diff --git a/dev-java/ant-junit/ant-junit-1.7.1.ebuild b/dev-java/ant-junit/ant-junit-1.7.1.ebuild
new file mode 100644
index 000000000000..a966de6603cc
--- /dev/null
+++ b/dev-java/ant-junit/ant-junit-1.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit/ant-junit-1.7.1.ebuild,v 1.1 2008/07/14 21:59:18 caster Exp $
+
+EAPI=1
+
+inherit ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# xalan is a runtime dependency of the XalanExecutor task
+# which was for some reason moved to ant-junit by upstream
+DEPEND="dev-java/junit:0"
+RDEPEND="${DEPEND}
+ dev-java/xalan:0"
+
+src_compile() {
+ eant jar-junit
+}
+
+src_install() {
+ ant-tasks_src_install
+ java-pkg_register-dependency xalan
+}