summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-06-11 16:21:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-06-11 16:21:56 +0000
commit2bf719755e96573641bd463b99a7304154e99621 (patch)
treed2a6d239f5a366d1432d8cb41436d12ad64a51ea /dev-cpp/asio
parentremove old version (diff)
downloadhistorical-2bf719755e96573641bd463b99a7304154e99621.tar.gz
historical-2bf719755e96573641bd463b99a7304154e99621.tar.bz2
historical-2bf719755e96573641bd463b99a7304154e99621.zip
Version bump.
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/ChangeLog7
-rw-r--r--dev-cpp/asio/Manifest4
-rw-r--r--dev-cpp/asio/asio-1.1.0.ebuild51
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index 56d69ca37aba..3b7e074a996c 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/asio
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.14 2008/02/05 23:43:27 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.15 2008/06/11 16:21:56 drac Exp $
+
+*asio-1.1.0 (11 Jun 2008)
+
+ 11 Jun 2008; Samuli Suominen <drac@gentoo.org> +asio-1.1.0.ebuild:
+ Version bump.
05 Feb 2008; Tiziano Müller <dev-zero@gentoo.org>
-files/asio-0.3.7-recursive_init.patch, -asio-0.3.7.ebuild:
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 356363dc9306..997713cb3bbb 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,4 +1,6 @@
DIST asio-0.3.9.tar.bz2 553708 RMD160 22bf83006de480d13dd0a28a4f0b5e7beceb19b4 SHA1 9fe14d320affb86f7fba4f0b9e08b3560ce56772 SHA256 41e96d922ae0a1051e3a4d39f0787f3e054f301e1ebeccd53fcfeced56e96680
+DIST asio-1.1.0.tar.bz2 610504 RMD160 4d1e02e10b86aea6ab0842157d284f879b0967ec SHA1 9a00997e588515ef84f3874c8df93ae9ecbc7238 SHA256 b4f2a55f24c31bf0b5ce77a069a8a2174dd1a66a723dec789fc573e325fdbeb5
EBUILD asio-0.3.9.ebuild 1066 RMD160 738c448d7c12eb9737d08d9ca244854a4c0e2f10 SHA1 37fa74c4d1cd192924e76d389dbcd98a7fd08eb7 SHA256 7776959f3a2e9381a9effabd16dda6950675386e6f4cf4896fca7320710d6fde
-MISC ChangeLog 2088 RMD160 9806041cd72ec13e699fcdd20c1e4bbfc1847b3f SHA1 c2beb0bc9a85d03d5876f484d390d9a769fa2800 SHA256 4ab62ee70095fa623ffe363313d978a81107aea8826a23f76a9ba119dd6f9d92
+EBUILD asio-1.1.0.ebuild 1051 RMD160 7fb5351d60c406ae007a5078686cbd0dbf5091b9 SHA1 13a21e8fb263f584b7b2bfca421f1260f067b197 SHA256 2f524fc44d8b192ce5da824ea61353f43d0bab097b9dd2f0db105a525d1a9a2c
+MISC ChangeLog 2197 RMD160 52ea4907757284fcd858e51551dfb159dd70c127 SHA1 1f73ba2bb1a9f07552fc08cb7e1ddd0406e5f008 SHA256 5565e923f5aa149d0a60fa32eb5bb3dd2b37e79fb71d7a1ce1a40d653895289d
MISC metadata.xml 156 RMD160 537178ef5a820896e97475fb9aded47d50474bef SHA1 2a4ef4879b918a28132d21cd6d1bbaa2a30dccde SHA256 0e8490f9c62cb74e5894b52f643a02de0024d97dbfebad43082dce6bcb39555f
diff --git a/dev-cpp/asio/asio-1.1.0.ebuild b/dev-cpp/asio/asio-1.1.0.ebuild
new file mode 100644
index 000000000000..ae6e76a14ee3
--- /dev/null
+++ b/dev-cpp/asio/asio-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-1.1.0.ebuild,v 1.1 2008/06/11 16:21:56 drac Exp $
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples ssl test"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.34.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use test ; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+ if use examples ; then
+
+ if use test ; then
+ # Get rid of the object files
+ emake clean || die "emake clean failed"
+ fi
+
+ insinto /usr/share/doc/${PF}
+ doins -r src/examples
+ fi
+}