summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 22:23:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 22:23:41 +0000
commitfab5b5323c967adf4eac025cb94c9012e34cb50c (patch)
tree63364edfad739e3765f2a0e3640dd56beb93a454 /app-shells/csh
parentrepoman: trim trailing whitespace (diff)
downloadhistorical-fab5b5323c967adf4eac025cb94c9012e34cb50c.tar.gz
historical-fab5b5323c967adf4eac025cb94c9012e34cb50c.tar.bz2
historical-fab5b5323c967adf4eac025cb94c9012e34cb50c.zip
repoman: trim trailing whitespace
Diffstat (limited to 'app-shells/csh')
-rw-r--r--app-shells/csh/Manifest12
-rw-r--r--app-shells/csh/csh-1.29-r1.ebuild32
-rw-r--r--app-shells/csh/csh-1.29.ebuild24
3 files changed, 34 insertions, 34 deletions
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index b2d16ed71a11..e8350534f42a 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,13 +1,13 @@
-MD5 24974796f8712ee41f927e1e76ff5a70 csh-1.29.ebuild 3803
-MD5 c9ed16e56100fb9511e19c7e00371705 csh-1.29-r1.ebuild 4060
-MD5 5ecf5bef3e3cad1ca1311c11fe6fe8a0 csh-1.29-r2.ebuild 4314
MD5 3019bbce2833e8d5a8fd63babed04252 ChangeLog 2127
+MD5 c8862976a0b170f264c5ad49eea885f3 csh-1.29.ebuild 3796
+MD5 a4db08fd328f9b461fd2db64f8dd401c csh-1.29-r1.ebuild 4044
MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
-MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
+MD5 5ecf5bef3e3cad1ca1311c11fe6fe8a0 csh-1.29-r2.ebuild 4314
MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
+MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 70a304fe872eabbec7c515095af358fc files/digest-csh-1.29-r1 162
-MD5 8eb726131df145785642164034fb5a74 files/digest-csh-1.29-r2 60
-MD5 9a4c41baf0e48fb12e83a51b0b15f297 files/retype-input.diff 2352
MD5 56092454f21f9d462f4514aadf4c78cd files/dot.cshrc 1549
MD5 2365e5e2ca11496be2169a6944a38994 files/dot.login 224
+MD5 8eb726131df145785642164034fb5a74 files/digest-csh-1.29-r2 60
+MD5 9a4c41baf0e48fb12e83a51b0b15f297 files/retype-input.diff 2352
diff --git a/app-shells/csh/csh-1.29-r1.ebuild b/app-shells/csh/csh-1.29-r1.ebuild
index e12ba46e9fe4..040f6305ea7c 100644
--- a/app-shells/csh/csh-1.29-r1.ebuild
+++ b/app-shells/csh/csh-1.29-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.6 2003/06/24 20:22:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.7 2003/09/06 22:23:39 msterret Exp $
inherit flag-o-matic eutils ccc
@@ -33,8 +33,8 @@ src_compile() {
${WORKDIR}/vis.c \
${FILESDIR}/dot.login \
${FILESDIR}/dot.cshrc \
- ${S}
-
+ ${S}
+
# this parses the output of the bash builtin `kill`
# and creates an array of signal names for csh.
@@ -45,20 +45,20 @@ src_compile() {
printf "/* automatically generated during %s build */\n\n" ${PF} > ${S}/signames.h
printf "const char *const sys_signame[NSIG + 3] = {\n" >> ${S}/signames.h
printf "\t\"EXIT\",\t\n" >> ${S}/signames.h
-
+
let cnt++
-
+
for i in `kill -l`
do
let $((cnt++))%2 && continue
einfo " Adding ${i}..."
printf "\t\"%s\",\n" ${i} >> ${S}/signames.h
done
-
+
printf "\t\"DEBUG\",\n\t\"ERR\",\n\t(char *)0x0\n};\n\n" >> ${S}/signames.h
einfo "Adding flags required for succesful compilation..."
- # this should be easier than maintaining a patch.
+ # this should be easier than maintaining a patch.
for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
do
append-flags ${i}
@@ -73,20 +73,20 @@ src_compile() {
# maybe they dont warn on BSD, but _damn_.
export NOGCCERROR=1
-
+
# if csh is a users preferred shell, they may want
# a static binary to help on the event of fs emergency.
use static && append-ldflags -static
-
+
# pmake is a portage binary as well, so specify full path.
# if yours isnt in /usr/bin, you can set PMAKE_PATH.
einfo "Starting build..."
${PMAKE_PATH:-/usr/bin/}pmake || die "compile failed."
-
+
echo
- size csh
+ size csh
echo
-
+
# make the c shell guide
use doc && {
einfo "Making documentation..."
@@ -96,7 +96,7 @@ src_compile() {
cd ${S}
einfo "Making empty configuration files.."
- printf "#\n# System-wide .cshrc file for csh(1).\n\n" > csh.cshrc
+ printf "#\n# System-wide .cshrc file for csh(1).\n\n" > csh.cshrc
printf "#\n# System-wide .login file for csh(1).\n\n" > csh.login
printf "if ( -f /etc/csh.env ) source /etc/csh.env\n" >> csh.login
printf "#\n# System-wide .logout file for csh(1).\n\n" > csh.logout
@@ -105,12 +105,12 @@ src_compile() {
src_install() {
exeinto /bin
doexe csh
-
+
doman csh.1
-
+
use doc && dodoc USD.doc/paper.ps
dodoc dot.cshrc dot.login
-
+
insinto /etc
doins csh.cshrc csh.login csh.logout
}
diff --git a/app-shells/csh/csh-1.29.ebuild b/app-shells/csh/csh-1.29.ebuild
index 8b2a2eabb619..5de5d343b7f8 100644
--- a/app-shells/csh/csh-1.29.ebuild
+++ b/app-shells/csh/csh-1.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29.ebuild,v 1.5 2003/07/02 12:47:28 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29.ebuild,v 1.6 2003/09/06 22:23:39 msterret Exp $
inherit cvs flag-o-matic eutils ccc
@@ -18,13 +18,13 @@ SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/usr.bin/printf/p
RESTRICT="nomirror"
-# theres basically a choice of fetching the individual files via
-# ftp, and using nomirror to stop spamming the mirrors, or fetch
+# theres basically a choice of fetching the individual files via
+# ftp, and using nomirror to stop spamming the mirrors, or fetch
# a tarball of the whole lot and waste bandwidth.
-#
-# the other option is to check it out of cvs, using tags to make
-# sure we get a consistent version.
-#
+#
+# the other option is to check it out of cvs, using tags to make
+# sure we get a consistent version.
+#
# i decided to go with cvs.
LICENSE="BSD GPL-2"
@@ -50,14 +50,14 @@ src_compile() {
# The file `mksignames.c` and the product of its execution
# is the only reason this ebuild is dual license, without
- # this code (eg make your own array) this shell will be
+ # this code (eg make your own array) this shell will be
# 100% BSD. i borrowed it from bash-2.05b, btw.
cd ${S}; cp ${DISTDIR}/printf.c \
${DISTDIR}/vis.h \
${FILESDIR}/mksignames.c \
${DISTDIR}/vis.c \
- ${S}
+ ${S}
# this utility spits out an array of signal names.
einfo "Making a list of signal names..."
@@ -65,7 +65,7 @@ src_compile() {
${T}/mksignames > ${S}/signames.h || die "couldnt get a list of signals."
einfo "Adding flags required for succesful compilation..."
- # this should be easier than maintaining a patch.
+ # this should be easier than maintaining a patch.
for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
do
append-flags ${i}
@@ -79,11 +79,11 @@ src_compile() {
# maybe they dont warn on BSD, but _damn_.
export NOGCCERROR=1
-
+
# if csh is a users preferred shell, they may want
# a static binary to help on the event of fs emergency.
use static && append-ldflags -static
-
+
# pmake is a portage binary as well, so specify full path.
# if yours isnt in /usr/bin, you can set PMAKE_PATH.
einfo "Starting build..."