summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-04 10:56:25 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-04 10:56:25 +0000
commit475afc629ec0eda15053ad2fcbc3b2555f532372 (patch)
tree209b3fb25511bc79315d39ef125e9e0bbae3d89f /app-misc
parentRespect LDFLAGS (bug 429664, thanks flameeyes for the report and pinkbyte for... (diff)
downloadhistorical-475afc629ec0eda15053ad2fcbc3b2555f532372.tar.gz
historical-475afc629ec0eda15053ad2fcbc3b2555f532372.tar.bz2
historical-475afc629ec0eda15053ad2fcbc3b2555f532372.zip
Respect LDFLAGS (bug 429664, thanks flameeyes for the report and pinkbyte for the suggested fix).
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/empty/ChangeLog6
-rw-r--r--app-misc/empty/empty-0.6.18b.ebuild8
-rw-r--r--app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch11
3 files changed, 22 insertions, 3 deletions
diff --git a/app-misc/empty/ChangeLog b/app-misc/empty/ChangeLog
index 66b12fcb29d2..85120ed249c4 100644
--- a/app-misc/empty/ChangeLog
+++ b/app-misc/empty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/empty
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/ChangeLog,v 1.2 2012/08/04 10:54:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/ChangeLog,v 1.3 2012/08/04 10:56:25 xmw Exp $
+
+ 04 Aug 2012; Michael Weber <xmw@gentoo.org> empty-0.6.18b.ebuild:
+ Respect LDFLAGS (bug 429664, thanks flameeyes for the report and pinkbyte for
+ the suggested fix).
04 Aug 2012; Michael Weber <xmw@gentoo.org>
+files/empty-0.6.18b-respect-LDFLAGS.patch, empty-0.6.18b.ebuild:
diff --git a/app-misc/empty/empty-0.6.18b.ebuild b/app-misc/empty/empty-0.6.18b.ebuild
index 544738568442..c5b4172515b4 100644
--- a/app-misc/empty/empty-0.6.18b.ebuild
+++ b/app-misc/empty/empty-0.6.18b.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/empty-0.6.18b.ebuild,v 1.2 2012/08/04 10:54:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/empty-0.6.18b.ebuild,v 1.3 2012/08/04 10:56:25 xmw Exp $
EAPI="4"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Small shell utility, similar to expect(1)"
HOMEPAGE="http://empty.sourceforge.net"
@@ -21,6 +21,10 @@ src_prepare() {
epatch "${FILESDIR}/${P}-respect-LDFLAGS.patch"
}
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
src_install() {
dobin empty
doman empty.1
diff --git a/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch b/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..f839afcf28c9
--- /dev/null
+++ b/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- empty-0.6.18b/Makefile
++++ empty-0.6.18b/Makefile
+@@ -16,7 +16,7 @@
+ PREFIX = /usr/local
+
+ all:
+- ${CC} ${CFLAGS} -Wall ${LIBS} -o empty empty.c
++ ${CC} ${CFLAGS} ${LDFLAGS} empty.c ${LIBS} -o empty
+
+ FreeBSD: all
+ NetBSD: all