summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-10-30 13:24:19 +0000
committerNed Ludd <solar@gentoo.org>2005-10-30 13:24:19 +0000
commit688268bebf000359b85ef0ce5987f1214a9056ba (patch)
tree91aca7f82be292ccf338d0b188788074d157c634 /app-misc/pax-utils/pax-utils-0.1.4.ebuild
parentFix broken digest. (diff)
downloadhistorical-688268bebf000359b85ef0ce5987f1214a9056ba.tar.gz
historical-688268bebf000359b85ef0ce5987f1214a9056ba.tar.bz2
historical-688268bebf000359b85ef0ce5987f1214a9056ba.zip
- version bump. This release adds 3 scanelf options. -S, -b, -g
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'app-misc/pax-utils/pax-utils-0.1.4.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.1.4.ebuild b/app-misc/pax-utils/pax-utils-0.1.4.ebuild
new file mode 100644
index 000000000000..ab1e768404d2
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.1.4.ebuild,v 1.1 2005/10/30 13:24:19 solar Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful for displaying PaX and security info on a large groups of bins"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_compile() {
+ if use caps ; then
+ append-flags -DWANT_SYSCAP
+ append-ldflags -lcap
+ fi
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}