summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-14 22:33:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-14 22:33:14 +0000
commitd10d3838b32400c81827bedd7cf4a9ce430f4bb7 (patch)
tree07f1c5131c45dc5f3ba13225e2c11f7a155b7b0d /app-emulation
parentVersion bumped. Ebuild submitted by Chris Ripp (chris@ripp.net) in #18838. (diff)
downloadhistorical-d10d3838b32400c81827bedd7cf4a9ce430f4bb7.tar.gz
historical-d10d3838b32400c81827bedd7cf4a9ce430f4bb7.tar.bz2
historical-d10d3838b32400c81827bedd7cf4a9ce430f4bb7.zip
Version bumped. Ebuild submitted by Chris Ripp (chris@ripp.net) in #18838.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/stella/Manifest4
-rw-r--r--app-emulation/stella/files/digest-stella-1.31
-rw-r--r--app-emulation/stella/stella-1.3.ebuild50
3 files changed, 53 insertions, 2 deletions
diff --git a/app-emulation/stella/Manifest b/app-emulation/stella/Manifest
index 6e48ff3ee839..0a1c49ebeb91 100644
--- a/app-emulation/stella/Manifest
+++ b/app-emulation/stella/Manifest
@@ -1,5 +1,5 @@
-MD5 13262b5f064f53789d3f3ad1c979e421 ChangeLog 376
+MD5 0a275fd8b43e1cd300fdbd72f2a7abee ChangeLog 561
MD5 12d7455ad9a7af4b39cfc6fa077c61d9 stella-1.2.ebuild 1112
-MD5 3ea07fba6c04dbd62adf5fe911227db5 stella-1.3.ebuild 1261
+MD5 e62caf521d01dff3082772b3760bbc5f stella-1.3.ebuild 1262
MD5 4ed8ab29f9d3ab27873b12516dfd9fdf files/digest-stella-1.2 66
MD5 5af9244b91231a9124ae00e7620ad00e files/digest-stella-1.3 66
diff --git a/app-emulation/stella/files/digest-stella-1.3 b/app-emulation/stella/files/digest-stella-1.3
new file mode 100644
index 000000000000..b3e8bbc9f312
--- /dev/null
+++ b/app-emulation/stella/files/digest-stella-1.3
@@ -0,0 +1 @@
+MD5 b9318f82a180ff0a404fca78511b2772 stella-1.3-src.tar.gz 433201
diff --git a/app-emulation/stella/stella-1.3.ebuild b/app-emulation/stella/stella-1.3.ebuild
new file mode 100644
index 000000000000..1f35dd3431bb
--- /dev/null
+++ b/app-emulation/stella/stella-1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/stella/stella-1.3.ebuild,v 1.1 2003/04/14 22:33:02 mholzer Exp $
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="sdl oss X alsa"
+
+DEPEND="|| (
+ X? ( virtual/x11 )
+ sdl? ( media-libs/libsdl )
+ virtual/x11
+ alsa? ( media-sound/alsa-driver )
+ media-libs/libpng
+ )"
+
+src_compile() {
+ # let's just default joystick & snapshot support to on
+ MYOPTS="JOYSTICK_SUPPORT=1 SNAPSHOT_SUPPORT=1"
+
+ if [ `use alsa` ] ; then
+ MYOPTS="${MYOPTS} SOUND_ALSA=1"
+ fi
+ if [ `use X` ] || [ -z "`use X``use sdl`" ] ; then
+ cd ${S}/src/build
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x || die
+ fi
+ if [ `use sdl` ] ; then
+ cd ${S}/src/build
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl || die
+ fi
+}
+
+src_install() {
+ use X && dobin src/build/stella.x11
+ use sdl && dobin src/build/stella.sdl
+ [ -z "`use X``use sdl`" ] && dobin src/build/stella.x11
+
+ insinto /etc
+ doins src/stellarc
+ doins src/emucore/stella.pro
+
+ dohtml -r docs/
+ dodoc *.txt
+}