summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-05-24 06:38:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-05-24 06:38:54 +0000
commitfa9f09e2810eca033212472242cb1a1e6eb374da (patch)
treebce42a2546fe563c6f5764f1c4e3114a09b0ae3c /app-crypt/mhash/mhash-0.9.1.ebuild
parentFixing bug #48137 (diff)
downloadhistorical-fa9f09e2810eca033212472242cb1a1e6eb374da.tar.gz
historical-fa9f09e2810eca033212472242cb1a1e6eb374da.tar.bz2
historical-fa9f09e2810eca033212472242cb1a1e6eb374da.zip
bug #49962, version bump.
Diffstat (limited to 'app-crypt/mhash/mhash-0.9.1.ebuild')
-rw-r--r--app-crypt/mhash/mhash-0.9.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/mhash/mhash-0.9.1.ebuild b/app-crypt/mhash/mhash-0.9.1.ebuild
new file mode 100644
index 000000000000..d86e27324814
--- /dev/null
+++ b/app-crypt/mhash/mhash-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.1.ebuild,v 1.1 2004/05/24 06:38:54 robbat2 Exp $
+
+DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+HOMEPAGE="http://mhash.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 s390"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+
+src_compile() {
+ local myconf
+ myconf="--enable-static --enable-shared"
+ econf ${myconf} || die
+ emake || die "make failure"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib}
+ einstall || die "install failure"
+
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO THANKS ChangeLog
+ dodoc doc/*.txt doc/skid*
+ prepalldocs
+ cd doc && dohtml mhash.html || die "dohtml failed"
+}