summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-06-06 21:51:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-06-06 21:51:25 +0000
commitbfccc1e816beabcddd6b2a99a9f8bb64a9882671 (patch)
treea191df079d5ba9e47ab582b27afea5a56d990bdc /app-crypt/heimdal
parentlibnss-mysql masking. (diff)
downloadhistorical-bfccc1e816beabcddd6b2a99a9f8bb64a9882671.tar.gz
historical-bfccc1e816beabcddd6b2a99a9f8bb64a9882671.tar.bz2
historical-bfccc1e816beabcddd6b2a99a9f8bb64a9882671.zip
fix compile issue if heimdal is installed without existing heimdal in place. silly me.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/Manifest2
-rw-r--r--app-crypt/heimdal/heimdal-0.6.4-r1.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/app-crypt/heimdal/Manifest b/app-crypt/heimdal/Manifest
index 007491960902..aca6402067a0 100644
--- a/app-crypt/heimdal/Manifest
+++ b/app-crypt/heimdal/Manifest
@@ -1,7 +1,7 @@
MD5 277df3ab3d4819d7e702651a12cac06c ChangeLog 11670
MD5 6c9cbfc951ebeca1a88d8722de4dde80 metadata.xml 231
MD5 8ff78d3463eb4bbfdd4d0cdf29ac937c heimdal-0.6.4.ebuild 2805
-MD5 b5b31e9e46d2c60ddfed9a84f7f3601f heimdal-0.6.4-r1.ebuild 3384
+MD5 d49eac5c9e56a2171936b327adaebbc0 heimdal-0.6.4-r1.ebuild 3399
MD5 0becad2fb5b2e15b30b47b2939304647 files/heimdal-kadmind 546
MD5 2be6ab7b49a076e078f34913d65bcaad files/heimdal-kdc 514
MD5 f4811d443f68fe11946a031ada8ce125 files/heimdal-kpasswdd 551
diff --git a/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild b/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild
index 0bf10cae9be3..648e6b794c98 100644
--- a/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild,v 1.2 2005/06/06 20:02:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.6.4-r1.ebuild,v 1.3 2005/06/06 21:51:25 seemant Exp $
inherit libtool eutils virtualx toolchain-funcs
@@ -76,7 +76,7 @@ src_compile() {
# Compile the added password checker:
cd ${S}/lib/kadm5
tc-export CC
- ${CC} -shared -fPIC ${CFLAGS} \
+ ${CC} -shared -fPIC ${CFLAGS} -I${S}/include \
-o sample_passwd_check.so sample_passwd_check.c -lcrack || \
die "Failed to compile password checker"