summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-03-13 15:18:02 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-03-13 15:18:02 +0000
commitdb42538df3582e81dd711f7134ccf2997c4e101c (patch)
tree9eb2bcccf063098dd9242271be152eb84fa03e05
parentstable on x86 (diff)
downloadhistorical-db42538df3582e81dd711f7134ccf2997c4e101c.tar.gz
historical-db42538df3582e81dd711f7134ccf2997c4e101c.tar.bz2
historical-db42538df3582e81dd711f7134ccf2997c4e101c.zip
new snapshot
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/Manifest4
-rw-r--r--net-misc/putty/files/digest-putty-200403131
-rw-r--r--net-misc/putty/putty-20040313.ebuild69
4 files changed, 78 insertions, 3 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 48f2af3c9973..9b283d91e1f6 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/putty
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.8 2003/10/29 16:48:08 taviso Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.9 2004/03/13 15:18:02 taviso Exp $
+
+ 13 Mar 2004; Tavis Ormandy <taviso@gentoo.org> :
+ new snapshot, i'll use bzip2 instead of gzip.
29 Oct 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030902-r1.ebuild:
code cleanups, moving makefile generation into src_unpack()
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 41f8d4bee30c..f738a4260320 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,4 +1,6 @@
MD5 27c2740c5ab57b401017d35b04b422db putty-20030902-r1.ebuild 1386
-MD5 db5ef4b19662d3734390b67cee9f915a ChangeLog 1326
+MD5 7ae9f7449dad5aa60ae33df39274b9aa putty-20040313.ebuild 1409
+MD5 f7767af63d36f659e1e959aff3f751c9 ChangeLog 1426
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
+MD5 d3c6f158244af5bb6cdd7bbda46e8dc6 files/digest-putty-20040313 71
MD5 68c88474593f165e89a7cf28fe98f555 files/digest-putty-20030902-r1 70
diff --git a/net-misc/putty/files/digest-putty-20040313 b/net-misc/putty/files/digest-putty-20040313
new file mode 100644
index 000000000000..aaf7b059b130
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-20040313
@@ -0,0 +1 @@
+MD5 4c658a8e61933c3fea48ee684ef31dfe putty-cvs-20040313.tar.bz2 699018
diff --git a/net-misc/putty/putty-20040313.ebuild b/net-misc/putty/putty-20040313.ebuild
new file mode 100644
index 000000000000..489fcd9e0a9a
--- /dev/null
+++ b/net-misc/putty/putty-20040313.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20040313.ebuild,v 1.1 2004/03/13 15:18:02 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="mirror://gentoo/putty-cvs-${PV}.tar.bz2"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="doc"
+
+RDEPEND="=x11-libs/gtk+-1.2* virtual/x11"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.0
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ # unpack the tarball...
+ unpack ${A}
+
+ # generate the makefiles
+ ebegin "Generating Makefiles"
+ cd ${S}; ${S}/mkfiles.pl
+ eend $?
+
+ # change the CFLAGS to those requested by user.
+ ebegin "Setting CFLAGS"
+ sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+ eend $?
+}
+
+src_compile() {
+ # build putty.
+ einfo "Building putty..."
+ cd ${S}/unix; emake -f Makefile.gtk || die
+}
+
+src_install() {
+
+ cd ${S}/unix
+
+ # man pages...
+ doman plink.1 pterm.1 putty.1 puttytel.1
+
+ # binaries...
+ dobin plink pterm putty puttytel psftp pscp
+
+ cd ${S}
+
+ # docs...
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url MODULE
+ use doc && dodoc doc/*
+
+ prepallman
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}