summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-16 16:11:43 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-16 16:11:43 +0000
commit86dea0fde521824f187f42060bf8b8ecca85965d (patch)
tree0337311176bebfc21486970bf08ead807967099d
parentStable for AMD64, wrt bug #393977 (diff)
downloadhistorical-86dea0fde521824f187f42060bf8b8ecca85965d.tar.gz
historical-86dea0fde521824f187f42060bf8b8ecca85965d.tar.bz2
historical-86dea0fde521824f187f42060bf8b8ecca85965d.zip
Version bump.
Package-Manager: portage-2.2.0_alpha81/cvs/Linux x86_64
-rw-r--r--net-analyzer/argus-clients/ChangeLog7
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.5.26.ebuild62
-rw-r--r--net-analyzer/argus/ChangeLog7
-rw-r--r--net-analyzer/argus/argus-3.0.5.7.ebuild73
4 files changed, 147 insertions, 2 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index e0c26ed58097..0e57ae3cce2c 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.29 2011/11/15 20:25:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.30 2011/12/16 16:08:50 jer Exp $
+
+*argus-clients-3.0.5.26 (16 Dec 2011)
+
+ 16 Dec 2011; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.5.26.ebuild:
+ Version bump.
*argus-clients-3.0.5.24 (15 Nov 2011)
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.5.26.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.5.26.ebuild
new file mode 100644
index 000000000000..de17bcf364cf
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.5.26.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.5.26.ebuild,v 1.1 2011/12/16 16:08:50 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql tcpd"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="
+ net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sys-libs/ncurses
+"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="
+ ${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 4ee1ef77407b..d62ff909ac4e 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.37 2011/11/15 21:18:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.38 2011/12/16 16:11:43 jer Exp $
+
+*argus-3.0.5.7 (16 Dec 2011)
+
+ 16 Dec 2011; Jeroen Roovers <jer@gentoo.org> +argus-3.0.5.7.ebuild:
+ Version bump.
15 Nov 2011; Jeroen Roovers <jer@gentoo.org> argus-3.0.5.6.ebuild,
files/argus-3.0.5-Makefile.patch:
diff --git a/net-analyzer/argus/argus-3.0.5.7.ebuild b/net-analyzer/argus/argus-3.0.5.7.ebuild
new file mode 100644
index 000000000000..2dea9974a0d2
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.5.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.7.ebuild,v 1.1 2011/12/16 16:11:43 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}