summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.11.0-gcc5.2.patch16
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/sci-libs/libcmatrix/files/libcmatrix-3.11.0-gcc5.2.patch b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-gcc5.2.patch
new file mode 100644
index 000000000000..d5d40246a2f8
--- /dev/null
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-gcc5.2.patch
@@ -0,0 +1,16 @@
+ include/MultiMatrix.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/MultiMatrix.h b/include/MultiMatrix.h
+index 2d54db5..e95ce4c 100755
+--- a/include/MultiMatrix.h
++++ b/include/MultiMatrix.h
+@@ -1225,7 +1225,7 @@ template<class T,size_t N> struct new_trait_<T,N,N> { typedef MultiMatrix<T,N> v
+ #endif
+ //LCM_SUPPRESS_VIEWS
+
+- template<size_t N, template<size_t> class CheckClass =LCM_CheckBoundsDefault>
++ template<size_t N, template<size_t> class CheckClass>
+ class Indexer<N,CheckClass>::permuted_iterator : public ::std::iterator< ::std::bidirectional_iterator_tag,size_t>
+ {
+ private:
diff --git a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild b/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
index 84ec50c0b9d3..e4b2694e46e2 100644
--- a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
+++ b/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/3.2.1-gcc4.6.patch
"${FILESDIR}"/3.2.1-gcc4.7.patch
"${FILESDIR}"/3.9.0-atlas.patch
+ "${FILESDIR}"/${P}-gcc5.2.patch
)
AUTOTOOLS_IN_SOURCE_BUILD=1