summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/systemc')
-rw-r--r--sci-electronics/systemc/systemc-2.3.4-r1.ebuild (renamed from sci-electronics/systemc/systemc-2.3.4.ebuild)24
1 files changed, 13 insertions, 11 deletions
diff --git a/sci-electronics/systemc/systemc-2.3.4.ebuild b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
index b9efef41568a..4669cd8f6d9b 100644
--- a/sci-electronics/systemc/systemc-2.3.4.ebuild
+++ b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
@@ -24,11 +24,10 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="debug static-libs test"
+IUSE="debug doc examples static-libs test"
+REQUIRED_USE="examples? ( doc )"
RESTRICT="!test? ( test )"
-DOCS=(AUTHORS.md CONTRIBUTING.md INSTALL.md LICENSE NOTICE README.md RELEASENOTES)
-
src_prepare() {
default
eautoconf --force
@@ -41,12 +40,15 @@ src_configure() {
--with-unix-layout
}
-pkg_postinst() {
- elog "If you want to run the examples, you need to :"
- elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
- elog " cd ${PN}-${MY_PV}"
- elog " mkdir build && cd build"
- elog " cmake .."
- elog " cd examples"
- elog " make check"
+src_install() {
+ default
+ if use doc; then
+ if use examples; then
+ docompress -x /usr/share/doc/"${PF}"/examples
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}"/examples || die
+ fi
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}" || die
+ fi
}