summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/git-cola-4.1.0.ebuild6
-rw-r--r--dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild6
-rw-r--r--dev-vcs/git-cola/git-cola-4.4.1.ebuild3
3 files changed, 10 insertions, 5 deletions
diff --git a/dev-vcs/git-cola/git-cola-4.1.0.ebuild b/dev-vcs/git-cola/git-cola-4.1.0.ebuild
index b4db3a7d1dfa..09761dd50b1e 100644
--- a/dev-vcs/git-cola/git-cola-4.1.0.ebuild
+++ b/dev-vcs/git-cola/git-cola-4.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_SINGLE_IMPL=true
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
@@ -29,8 +29,10 @@ RDEPEND="
')
dev-vcs/git
"
-BDEPEND="sys-devel/gettext
+BDEPEND="
+ sys-devel/gettext
$(python_gen_cond_dep "
+ dev-python/setuptools-scm[\${PYTHON_USEDEP}]
test? (
${VIRTUALX_DEPEND}
dev-python/pytest[\${PYTHON_USEDEP}]
diff --git a/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild b/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild
index 14d1a8b01c21..6edb3f03319f 100644
--- a/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild
+++ b/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_SINGLE_IMPL=true
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
@@ -29,8 +29,10 @@ RDEPEND="
')
dev-vcs/git
"
-BDEPEND="sys-devel/gettext
+BDEPEND="
+ sys-devel/gettext
$(python_gen_cond_dep "
+ dev-python/setuptools-scm[\${PYTHON_USEDEP}]
test? (
${VIRTUALX_DEPEND}
dev-python/pytest[\${PYTHON_USEDEP}]
diff --git a/dev-vcs/git-cola/git-cola-4.4.1.ebuild b/dev-vcs/git-cola/git-cola-4.4.1.ebuild
index c2bc009b2da0..fe84fd6d276d 100644
--- a/dev-vcs/git-cola/git-cola-4.4.1.ebuild
+++ b/dev-vcs/git-cola/git-cola-4.4.1.ebuild
@@ -26,7 +26,8 @@ RDEPEND="
')
dev-vcs/git
"
-BDEPEND="sys-devel/gettext
+BDEPEND="
+ sys-devel/gettext
$(python_gen_cond_dep "
dev-python/setuptools-scm[\${PYTHON_USEDEP}]
test? (