summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-trio/pytest-trio-0.7.0.ebuild')
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
index d4e3ebf6eb24..371f976c7b91 100644
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -41,3 +41,11 @@ python_prepare_all() {
mv pytest_trio/_tests/conftest.py conftest.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}